cancel
Showing results for 
Search instead for 
Did you mean: 

Odd happening here!

Community Veteran
Posts: 1,375
Thanks: 33
Registered: 07-03-2008

Odd happening here!

Hi Folks!
A strange thing has somewhat puzzled me today. After  months of very good internet working Firefox seems to be unable to connect me with the world at large with an error message saying "Firefox does not know how to communicate with server". However if I type in the web site of a charity that I support it loads immediately!! Also if I select community forum in History, up it comes as you can see!,

I have selected this Forum as the most appropriate one, please shift this post.
Factors that are visible are:    1.  Lenovo E535 screen Internet Access indicator is on
                                                     2. PN Log In page has forgotten my  username and password, but typing them in lets me in.
                                                     3. I am guilty of tidying up some cabling at the back of the desk but did not disturb any any connections except the routing of some of the mains leads.
                                                     4. It all worked OK this morning before 3 above.
                                                     5. Router indictions on TP-Link TD-W8968 are quite normal, wired connection.
I hope that this is not finger trouble!!
2 REPLIES
thejudge
Grafter
Posts: 575
Thanks: 1
Registered: 01-08-2007

Re: Odd happening here!

What happens if you try it with all Firefox add-ons disabled? (Help > Restart with Add-ons Disabled > Restart).
If the problem doesn't occur then, then re-start Firefox as normal, update any Add-ons/Plugins, restart Firefox and then try it.
If the problem is still there after that, then disable add-ons/plugins one by one (a long-winded process, I know) to see if the problem goes away if one of them is disabled.
If that still doesn't get to the root of it, your Firefox profile may have become corrupted. Go to https://support.mozilla.org/en-US/products/firefox/fix-problems to take it from there.
HTH
Community Veteran
Posts: 1,375
Thanks: 33
Registered: 07-03-2008

Re: Odd happening here!

Thanks  Judge for your rapid reply.
As it happens I have just powered up and all seems to have got better!  I did wonder if Firefox had updated itself and, perhaps, did not complete the job. I will keep an eye on it and refer to your advice if I get a repeat performnce!! I do not have many addons installed and am happy with my current set-up.
I should have mentioned that I am on WIN 7 Professional which is upto date. A raft of  M$ updates did arrive yesterday but were all installed before I did anything useful so I did not worry about them.
I do not intend to upgrade to WIN 10,which looks like a possible source of problems in the future.