cancel
Showing results for 
Search instead for 
Did you mean: 

Non- Secure connection warning message

FIXED
Anonymous
Not applicable

Re: Non- Secure connection warning message

What you are seeing there @shutter is the same as this:

iMac:~ Mook$ openssl s_client -connect www.nationwide.co.uk:443 -tls1 -servername www.nationwide.co.uk | openssl x509 -text -noout
depth=0 1.3.6.1.4.1.311.60.2.1.3 = GB, businessCategory = Private Organization, serialNumber = 106078, C = GB, postalCode = SN38 1NW, ST = Wiltshire, L = Swindon, street = "Nationwide House, Pipers Way", O = Nationwide Building Society, OU = IT Infrastructure, CN = nationwide.co.uk
verify error:num=20:unable to get local issuer certificate
verify return:1
depth=0 1.3.6.1.4.1.311.60.2.1.3 = GB, businessCategory = Private Organization, serialNumber = 106078, C = GB, postalCode = SN38 1NW, ST = Wiltshire, L = Swindon, street = "Nationwide House, Pipers Way", O = Nationwide Building Society, OU = IT Infrastructure, CN = nationwide.co.uk
verify error:num=27:certificate not trusted
verify return:1
depth=0 1.3.6.1.4.1.311.60.2.1.3 = GB, businessCategory = Private Organization, serialNumber = 106078, C = GB, postalCode = SN38 1NW, ST = Wiltshire, L = Swindon, street = "Nationwide House, Pipers Way", O = Nationwide Building Society, OU = IT Infrastructure, CN = nationwide.co.uk
verify error:num=21:unable to verify the first certificate
verify return:1

Remaining output remove for brevity.


Now in order to eliminate the above error via the command line you would pass it the name of a Root CA file for example -CAfile NationWide.root.pem

@shutter have you tried my suggestion from post no 48, I think it may work for you!

Baldrick1
Hero
Posts: 3,774
Thanks: 1,657
Fixes: 105
Registered: ‎30-06-2016

Re: Non- Secure connection warning message

So if either the root certificate or the Nationwide one was corrupted then there would be an authentication error?

Community Veteran
Posts: 19,274
Thanks: 2,263
Fixes: 30
Registered: ‎06-11-2007

Re: Non- Secure connection warning message

@Anonymous Well, I tried that just now, before this answer...

just to confirm....

When I tried Nationwide from the Google search box.... https//:www.nationwide.co.uk  came back with the same insecure connection message....

 

 

MOOK SECURITY CHANGE 1.png

Anonymous
Not applicable

Re: Non- Secure connection warning message

Thanks @shutter are you able to try it once more having restarted the browser please just in case.

Also to undo the change select the item from the list, like you have done in the screen capture, right click on it and select "Reset" option.

 

Community Veteran
Posts: 19,274
Thanks: 2,263
Fixes: 30
Registered: ‎06-11-2007

Re: Non- Secure connection warning message

OK  I closed all open browser pages ( I don`t use tabs,... I use separate pages ).. and then went to the google search box... clicked on the Nationwide listing, and it came up with the insecure message again...

Do I have to change it back and do a reset now? or do you want me to play some thing more  ? 

Anonymous
Not applicable

Re: Non- Secure connection warning message

You can reset it, as the default is False.

@shutter, one more thing you could do is to show us what @bobpullen asked for above. In FireFox start by clicking the Open Menu button (it’s three vertical lines) and from there select Preferences, from the page displayed select “Privacy & Security” or enter 

about:preferences#privacy

into the URL bar of an empty window.

Preferences.png
Scroll to the bottom of the screen and in the Certificates section click the “View Certificates…” button.

Certificates.png
Scroll down the list of certificates until you come to “VeriSign, Inc.” in there you should see an entry called “Symantec Class 3 EV SSL CA -G3” double click on it to display the certificate.

VeriSign.png

Now take screen captures of both the General and Details tabs. When you select the Details tab select the entry that says “Serial Number” so it appears in the Field Value area of the dialog and then take the screen capture.

Close the open dialogs and then post what you have. If you can’t find the entry under VeriSign, Inc. then this will explain a lot. If this is the case I’ll export the certificate I have and send it to you where you can import it using the same dialog shown above using oddly enough the Import button.

Community Veteran
Posts: 19,274
Thanks: 2,263
Fixes: 30
Registered: ‎06-11-2007

Re: Non- Secure connection warning message

OK... give me a few minutes to digest and do that... ! .. 

First I will try to reset the first one...

 

Community Veteran
Posts: 19,274
Thanks: 2,263
Fixes: 30
Registered: ‎06-11-2007

Re: Non- Secure connection warning message

@Anonymous  Just when you thought it couldn`t get any worse...... After doing the reset ... and then doing the Firefox instructions.... I tried to post the pics on CYBERFOX... and.... Plusnet gives Youre Connection is not secure...

 

However... I am now using FIREFOX on the forum... and it is showing a green padlock... ( tried Nationwide on here, but still insecure message ).

here is the results from the FIrefox instructions..

 

moook certificates 01.pngmook certificates 02 symanitc.pngmook certificates 03 view cert.pngmook certificates 04 view details.png

Community Veteran
Posts: 19,274
Thanks: 2,263
Fixes: 30
Registered: ‎06-11-2007

Re: Non- Secure connection warning message

@Anonymous   did another "about:config" and used the toggle to change back to true, and the PlusNet page ( this one ) has returned to normal.... Nationwide is still showing insecure connection.

 

Anonymous
Not applicable

Re: Non- Secure connection warning message

Fix

OK, @shutter that's not the correct certificate so may well explain the issue, but I can see it appears to be the only Symantec one you have. I have exported my one and emailed it to you just, save it on your desktop then import and try the site again. Once it's imported you can delete it from your desktop.

 

 

Community Veteran
Posts: 19,274
Thanks: 2,263
Fixes: 30
Registered: ‎06-11-2007

Re: Non- Secure connection warning message

OK @Anonymous   Instructions required on how to import the copied certificate please...

Anonymous
Not applicable

Re: Non- Secure connection warning message

See your inbox @shutter.

 

Community Veteran
Posts: 19,274
Thanks: 2,263
Fixes: 30
Registered: ‎06-11-2007

Re: Non- Secure connection warning message

@Anonymous  CONGRATULATIONS !... your .crt file has done the trick, on both Firefox and Cyberfox.. ( had to do each one )..

My mistake was to copy the "text" from the email... and not the attachment !.. once I had that attachment on the desktop, it was "found" in the Import search and then I just followed the route ... 

Thanks for your help.... top of the class..

 

Mind You.... all these deserve my sincere Thank You, for your perseverence and for sticking with the problem to help get me sorted.... " Thank You all

@Anonymous   @Baldrick1  @TheRoadCrew  @bobpullen @VileReynard   and @anyone esle who put in their bits