cancel
Showing results for 
Search instead for 
Did you mean: 

Mini-ITX PSU testing?

FIXED
Community Veteran
Posts: 14,440
Thanks: 728
Fixes: 12
Registered: ‎01-08-2007

Mini-ITX PSU testing?

Hi

I seem to be entering a new phase of rotten luck!

While tinkering with the DNS / VPN on my mini-itx with its nice new silent 10A power supply, I found myself disabling the ethernet while using remote desktop. Yes, go on, laugh hard what a stupid thing it was to do - I admit it (and should know better having done the same stupid thing many times in the past). Anyway at that late hour, rather than crawl around under the desk unscrewing the monitor from the main PC and untangling the wires I opted to just hold the power button and turn off the mini system and sort it out hte next day.

So yesterday I gets around to it, plugs in the monitor and power supply, turn it on, HDD starts spinning but nothing else happens. No VGA signal, no constant rattling from the HDD showing that windows was booting, no nothing. First thing I thought was the board had fried. It was a disposal from ebay - the seller is still selling them and sold over 260 so far with more to go - and at the time I bought two.

So I pulled out the second one and plugged everything into that, same problem. Nothing worked other than the HDD spinning. Thought that can't be right so pulled out an old noisy ATX PSU and plugged that in. The board booted up perfectly. Plugged everything back into the first board (more ram) and that booted too.

So I clearly have a dodgy silent PSU. Here's the problem - there are two parts to it. It's a micro ITX power supply that plugs into the motherboard with some micro wizardy mounted on it in the electronics dept and then a 12V 10A DC adapter that plugs into that. Here's what I mean:

screenshot-924 screenshot-925

 

I've checked the 4 pin processor connector voltage, that is 12V. I've checked the voltage at the molex - yellow is 12V and red is 5V. The only thing I can conclude is that one of them PSU parts isn't supplying enough current - I had these same symptoms when i tried a 3A supply months back hoping i might get lucky lol. As the normal ATX PSU makes it all work there is clearly a power issue and to me, it looks like it's a lack of available current.

The 24pin connector i've no idea where to start. Also I've no idea how to test the DC adapter. Both parts came from different suppliers.

 

Help!

 

I need a new signature... i'm bored of the old one!
6 REPLIES
Community Veteran
Posts: 5,691
Thanks: 1,569
Fixes: 37
Registered: ‎16-10-2014

Re: Mini-ITX PSU testing?

@7up - What you could do is use both your ATX and Mini ITX supplies to see where the outage is. Plug in your ITX leaving out the 4 Pin CPU connector and feed the board from the ATX. If it boots then you know where the issue is, if it doesn’t swap it back and swap out the Molex etc until you can see where the issue is.

Community Veteran
Posts: 14,440
Thanks: 728
Fixes: 12
Registered: ‎01-08-2007

Re: Mini-ITX PSU testing?

The problem there is that the ATX PSU won't start up properly without a signal from the motherboard.

I know it's the micro ATX supply at fault so using the ATX PSU won't help me to determine that really. What I need to figure out is WHICH of the two mini-itx PSU parts is at fault - the small bit that plugs into the mobo or the DC adapter.

I can't think of anything I have that will draw up to 10A at 12V to test the latter with.

EDIT: Hang on yeah I see what you mean - test the smaller plug-in part to see if it's delivering the juice... but that then presumes that the 12V adapter is OK to start with for testing purposes...


Only thing i can think of is to wire the motherboard part to a car battery and see what happens that way? If it works then the mobo part is ok but if not then it's the DC adapter?

I need a new signature... i'm bored of the old one!
Highlighted
Community Veteran
Posts: 14,440
Thanks: 728
Fixes: 12
Registered: ‎01-08-2007

Re: Mini-ITX PSU testing?

Fix

@7up wrote:

 

EDIT:  <snip>


Only thing i can think of is to wire the motherboard part to a car battery and see what happens that way? If it works then the mobo part is ok but if not then it's the DC adapter?


Well that did the job... soldered a couple of wires onto a 2.5mm DC jack plug, clipped the other ends onto the car battery and plugged it into the pico ITX supply and hit the power button. Booted with no problems.

Tried the DC adapter again, no boot.

Now I know it's the DC adapter.

I need a new signature... i'm bored of the old one!
Community Veteran
Posts: 14,440
Thanks: 728
Fixes: 12
Registered: ‎01-08-2007

Re: Mini-ITX PSU testing?

UPDATE:

The seller has sent a replacement AC adapter (the black thing pictured) after saying that he'd send a tested replacement. It arrived in different bubble wrap to the other and has clearly been used / tested so I assumed it would work.

Naturally, it doesn't.

So I found myself thinking that there must be something amiss here. The first AC adapter worked fine - for hours until it was shut down - at that point it gave up.

So.. I found myself looking at the pico PSU with the 24pins. It definitely works when connected to a car battery - with almost unlimited current supply - but not when connected to the brick. So.. i dug through my emails to discover that it's a 250W unit and tracking it down on ebay, says "Maximum" input current of 17A.

 

Now correct me if I am wrong.. but the AC adapter with 10A output and a 250W max PSU should work okay with a 

board that has a TDP of just 13W right? - by that I mean just because it says 250W doesn't mean that it's going to actually draw enough current to output 250W does it? - It's a maximum not an actual output right? - More to the point if it won't work then why did it the first time?

With that said, it only works via the car battery so I'm now wondering if it actually does draw more amps than I thought even if the motherboard itself doesn't need all of that current?

 

So.. I looked at the 24pinner on ebay and it does say it's for car / auto use. It specifies 12V DC in however the last I checked, cig lighter socket voltages go up and down and aren't stable. So how on earth does one use this poxy 250W thing if it needs a stable 12V supply at a silly high amperage?

I need a new signature... i'm bored of the old one!
VileReynard
All Star
Posts: 11,211
Thanks: 307
Fixes: 11
Registered: ‎01-09-2007

Re: Mini-ITX PSU testing?

It says:-

DC Input: 12V
Output ATX: Max 250W
Standard 24pin ATX Power Connector
Appearance size: 55*35*13mm; PCB size: 55*22mm
Input Current: Max. 17A
Output ATX: 250W
Output Current +12V: 8A
Output Current +5V: 8A
Output Current +3.3V: 8A
Output Current +5VSB: 1.5A
Output Current -12V: 0.1A
Output Power: 250W

Apart from those numbers not adding up, which voltage is the problem?

Community Veteran
Posts: 14,440
Thanks: 728
Fixes: 12
Registered: ‎01-08-2007

Re: Mini-ITX PSU testing?

That's the whole point though, those are maximum ratings so it's irrelevant.

The manual for this mobo clearly states that it draws a max of just over 8A when tested and pushed hard - so this AC adapter should be able to do it.

Current affects power... so 12V x 8.5A = 102W (at maximum consumption).

I'm stumped! I can only think that teh pico PSU is drawing more current than it actually needs to or the second ac adapter i've been sent has also decided to die after being used for testing by the seller. The latter seems unlikely but not the first time a batch of identical products has had the same fault..

I need a new signature... i'm bored of the old one!