cancel
Showing results for 
Search instead for 
Did you mean: 

MacBook won't connect to Plusnet router but other routers are fine.

FIXED
giratingtoad
Hooked
Posts: 5
Thanks: 1
Registered: ‎19-02-2018

MacBook won't connect to Plusnet router but other routers are fine.

When I try connecting my MacBook to my daughter's plusnet router when I visit her it just refuses to connect.  All our phones, and windows pcs connect flawlessley, but the Mac just shakes the screen at me and says the 'key is invalid' (yes, I'm typing it correctly). SOOOOO frustrating. I even logged into the plusnet router via a windows pc (actually the same MacBook booted off my secondary windows partition). I changed the security settings and key and yet when I try connecting the mac OS with these different credentials I still get the shaking screen and 'invalid key' error. My Mac just will not behave with PlusNet routers.

 

Apparently Plus net deny it is their problem, saying it is a problem from Apple. Has anybody else experienced this issue. There must be tons of you guys using Macs with Plusnet.

4 REPLIES 4
RPMozley
Pro
Posts: 1,271
Thanks: 56
Fixes: 9
Registered: ‎04-11-2011

Re: MacBook won't connect to Plusnet router but other routers are fine.

The usual advice given is to split the wifi 2.4ghz and 5ghz channels. Disable the synchronise and rename the SSID for one band.
That's RPM to you!!
giratingtoad
Hooked
Posts: 5
Thanks: 1
Registered: ‎19-02-2018

Re: MacBook won't connect to Plusnet router but other routers are fine.

I think the router only broadcasts one band. There's only ever one discoverable plusnet Wi-Fi signal in my daughter's home.
RPMozley
Pro
Posts: 1,271
Thanks: 56
Fixes: 9
Registered: ‎04-11-2011

Re: MacBook won't connect to Plusnet router but other routers are fine.

Fix
You only see one if they are synchronised. Login to the router and check there for the wifi setup.
That's RPM to you!!
giratingtoad
Hooked
Posts: 5
Thanks: 1
Registered: ‎19-02-2018

Re: MacBook won't connect to Plusnet router but other routers are fine.

Thanks for the suggestion. It worked a treat!