cancel
Showing results for 
Search instead for 
Did you mean: 

Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

Steve
Seasoned Pro
Posts: 6,817
Thanks: 315
Registered: 13-07-2009

Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

Ok so ive got lucid lynx on my p.c. and from first look its mighty impressive, For all you newbies out there heres a link to 10 must have apps.
Normally when a new release comes out, a lot of people  like to start over with a fresh install.
There are 3 reasons for doing it this way:
   * Distro updates sometimes work, sometimes fail and at other times they “sort of” work leaving you with a system that is not as snappy as it should be or has some other trouble which was not there before the upgrade.
   * You just need to backup the home folder and you are good to go, even that is not required if you have the home folder on a separate partition.
   * Installation takes about 20-30 minutes, all of which you can spend on Facebook/Twitter if you are installing using the Live CD.
This time around Ubuntu 10.04 is touting some great UI and design changes. Moreover, this being an LTS release, there are all the more reasons to go with the fresh install route. So if you decide to do so, come the 29th, here are some of the Ubuntu applications that you might want to install on a fresh Lucid Lynx install.
http://www.makeuseof.com/tag/10-applications-install-ubuntu-lucid-lynx/
If life gives you lemons, make lemonade.
28 REPLIES
Community Veteran
Posts: 1,128
Thanks: 8
Registered: 28-08-2007

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

I've been watching this release closely to see the comments, so far nothing bad being said really, I think I may give this a run out on one of my machines. Theres a lot of talk about 10.04 being business orientated which interests me.
If Linux's threat that so many business have M$ OS's on that there's a real threat from terrorism by creating a virus that can bring the world to a stand still rather than with a bomb everyone needs to install this as a matter of national security  Grin 
Steve
Seasoned Pro
Posts: 6,817
Thanks: 315
Registered: 13-07-2009

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

Ive been using windows seven but i wanted to try this, I installed Karmic Koala Then upgraded that to lucid lynx, It took me all afternoon but it was worth it, Everythings running fine and im hooked on it Smiley
If life gives you lemons, make lemonade.
Community Veteran
Posts: 1,128
Thanks: 8
Registered: 28-08-2007

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

Its starting to grow on me  Cool I've put Karmic Koala on four of my machines and so far havn't got a bad word to say as long as you just use whats already there or in the repos. I still haven't solved some wireless issues and the new kernel from an update I just did didn't like another of my machines(just went back to old kernel)
But yes other than that really impressed so far with what Ubuntu has to offer. One thing that impresses me is that out of the box 99% of is installed and ready to use and considering the diversity of machine thats impressive in itself.
I'm only new to Linux but I think I'll get on 10.04 right from the off on a machine thats not in a working environment and learn with everybody else as it develops.
VileReynard
Seasoned Pro
Posts: 10,980
Thanks: 265
Fixes: 11
Registered: 01-09-2007

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

@Average Smiley You might be interested to know that I did an upgrade via wireless from 9.10 to 10.04.
It spent hours downloading about 1.6GBytes, then as part of the upgrade process, told me that my network applet couldn't function any more and deleted it Cheesy
However, it installed a (better) replacement, asked for my WPA key again and everything is running nicely.

Steve
Seasoned Pro
Posts: 6,817
Thanks: 315
Registered: 13-07-2009

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

@ A Fox Is Evil i was hardwired when i was doing mine this afternoon and i got that same message, Still i ran to the end, Restarted and all is well.
If life gives you lemons, make lemonade.
Community Veteran
Posts: 1,128
Thanks: 8
Registered: 28-08-2007

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

Iwill definitely be going wired my wireless is still ropey, Im tempted to try it on the laptop so if the problem still persists at least ill solve it with something ill be using for a while.  I take it though this release candidate will just be getting updated and i wont have to do another install on final release ?  Fox m8 nightmare welcome to my worlld Crazy
VileReynard
Seasoned Pro
Posts: 10,980
Thanks: 265
Fixes: 11
Registered: 01-09-2007

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

This is the live production release version (not a candidate) - LTS (ie a very stable release, next LTS not due until April 2012).
Having said that, all new releases tend to get a higher number of patches etc

Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

I usually say wait for a week after the release of a new version (unless you know how to fix it) and wait for all the patches that will flood in after a greater audience sees the release version.
Community Veteran
Posts: 3,291
Thanks: 2
Registered: 10-08-2007

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

I wait 6 months
Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

If you wait 6 months then you are a release behind  Cheesy
Steve
Seasoned Pro
Posts: 6,817
Thanks: 315
Registered: 13-07-2009

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

It's the Meerkat Release Next In october, As a newbie myself to ubuntu what put me off was the releases every sixth month so in theory this is my 1st LTS with ubuntu and im staying put with it, Liking it very much Smiley
If life gives you lemons, make lemonade.
Community Veteran
Posts: 3,291
Thanks: 2
Registered: 10-08-2007

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

Quote from: Hairy
If you wait 6 months then you are a release behind  Cheesy

Correct
Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

Quote from: Steve
As a newbie myself to ubuntu what put me off was the releases every sixth month

The need to upgrade every 6 months is probably driven from a M$ POV. If you are happy with your current release then there is nothing to stop you keeping it for the next 18months (the length of time security updates will be available for it). Or 3 years if you go with a LTS version. A lot of people stay with LTS versions because of this. Others like the "churn" of upgrades every 6 months (myself included) If you want to be really up-to date then try Debian's SID release, it is constantly upgraded  Cheesy
Open Source Software is very fluid in updates, the GUI (Window Manager) is usually updated every 6 months and so newer "features" are included in the new version, but mostly they are not a cause to upgrade just to get a new widget  Tongue
There is nothing wrong or bad about running an older release, it maybe that your hardware will not run the latest version and so you stay with an older one, like when Ubuntu 9.04 changed the X manager and it broke a lot of installations. As long as you can get security updates and you  are happy why upgrade? The old axiom of don't fix it if it ain't broke comes to mind.
Take me, I am not a newbie at this, so I thought I would install FF 3.6 from the stable PPA. It installed then promptly fell over! So I just removed the PPA and re-installed 3.59! I can wait another month till Mint 9 is released to get it  Cool
Community Veteran
Posts: 1,128
Thanks: 8
Registered: 28-08-2007

Re: Lucid Lynx Is Here And Ive 10 MUST Have Application's For You To Install

Quote
  @Average Smiley You might be interested to know that I did an upgrade via wireless from 9.10 to 10.04.
It spent hours downloading about 1.6GBytes

Out of curiosity I have started downloading the desktop i386 torrent from here http://www.ubuntu.com/getubuntu/downloadmirrors because last time the download was corrupt from Ubuntu, torrents MD5 it when finished just wondering why the 1.6GB? The version I'm currently dloading is only 700mb  Shocked am I on the right version?
I thought it would help take the pressure off the servers if I helped to seed aswell.