cancel
Showing results for 
Search instead for 
Did you mean: 

LG TV apps cant connect after setting up second router at home

FIXED
Highlighted
bazmattaz
Newbie
Posts: 4
Registered: Thursday

LG TV apps cant connect after setting up second router at home

Hi all,

I'm having a weird issue that i cannot figure out. I have 35MB fibre broadband and a Hub One router/modem.

The WIFI from this router/modem has been really poor so I bought an ASUS RT- AC66U. I then swicthed of DHCP server on my Hub One and set the DHCP server settings on my ASUS RT-AC66U to point back to IP and gateway of the Hub One.

So the computers that are connected to the ASUS are all working fine. The Netflix app on LG TV is also working fine going through the ASUS.

However BCC Iplayer, ITV, Channel 4 and Plex apps on the LG TV all wont connect. Once I saw a message on the TV saying "unstable network".

There's something weird with how I've set up the ASUS router I think but I can't for life of me figure it out.

The ASUS is in router mode, not AP mode. I just set the DHCP to point to Hub One - is there something else i'm missing.

Thanks al!

7 REPLIES
SpendLessTime
Aspiring Hero
Posts: 2,797
Thanks: 816
Fixes: 80
Registered: ‎21-09-2009

Re: LG TV apps cant connect after setting up second router at home

Welcome to the forums @bazmattaz

Well you cannot have two routers inline so that is mostly likely the cause of your issues.

The Hub One only works as the modem/router. That cannot be altered.

So the Asus will need to be in access mode only to handle all the WiFi duties. 

SpendLessTime
Aspiring Hero
Posts: 2,797
Thanks: 816
Fixes: 80
Registered: ‎21-09-2009

Re: LG TV apps cant connect after setting up second router at home

bazmattaz
Newbie
Posts: 4
Registered: Thursday

Re: LG TV apps cant connect after setting up second router at home

Hey thanks for the speedy reply and the link to that post.

In that post is he using it as an Access Point though? Because he talks about disbaling DHCP and on the Hub one? I thought with access mode you keep DHCP on the hub one?

Thats really interesting that I ant have two routers in-line - makes sense I suppose.

Is there a way to disable to router element of the hub one and just use it's modem? Failing that I presume I'd need to buy a new modem that supports Plusnet Fibre and then use my ASUS as the main router?

SpendLessTime
Aspiring Hero
Posts: 2,797
Thanks: 816
Fixes: 80
Registered: ‎21-09-2009

Re: LG TV apps cant connect after setting up second router at home

Fix

Unfortunately the Hub One cannot be put into modem (bridge) only mode. It has to function as the router too and authenticate the service. That makes it easy for Plusnet to help the majority of their customers.

You are right and he doesn't actually mention what mode the Asus is put into. But it cannot be acting as a PPPoE router as that session is maintained by the Hub One.

There is a guide about using a Hub One as the second box for WiFi  at https://community.plus.net/t5/My-Router/Using-a-2nd-Plusnet-Hub1-as-a-Wireless-Access-point/td-p/138... so it would be possible to use your Asus as that second box. In that topic, the first Hub One does the DHCP work.

 

 

bazmattaz
Newbie
Posts: 4
Registered: Thursday

Re: LG TV apps cant connect after setting up second router at home

Hey thanks for all your help mate.

 

I decided to just switch to Access Point mode on the ASUS and switch the DHCP settings to ON on the Hub One

 

Now iPlayer and such work again on the TV!

 

SpendLessTime
Aspiring Hero
Posts: 2,797
Thanks: 816
Fixes: 80
Registered: ‎21-09-2009

Re: LG TV apps cant connect after setting up second router at home

bazmattaz
Newbie
Posts: 4
Registered: Thursday

Re: LG TV apps cant connect after setting up second router at home

The missus is very happy too Grin