cancel
Showing results for 
Search instead for 
Did you mean: 

KVM Disabled

Community Veteran
Posts: 7,988
Thanks: 635
Fixes: 8
Registered: 02-08-2007

KVM Disabled

Installed Mint 15 on to a recently purchased machine and keep getting the message KVM disabled by the BIOS.
Have had a look in the BIOS and disabled a couple of options in the boot menu relating to EUFI and changed it to legacy but the machine will not even load Mint until I revert to the previous settings.
D I need KVM ? Can I get rid of this message ( Mint 15 boots up ok after this message appears) ie can I use the terminal to stop this message appearing ?
11 REPLIES
Community Veteran
Posts: 6,610
Thanks: 209
Fixes: 15
Registered: 16-02-2009

Re: KVM Disabled

Strange message.
Have a look here (http://www.linux-kvm.org/page/FAQ)
& here http://askubuntu.com/questions/263179/get-rid-of-kvm-disabled-by-bios
But basically do this:-
Open a terminal
apt purge qemu-kvm
And the messages will disappear as if by magic.
kmilburn
Grafter
Posts: 902
Thanks: 2
Registered: 30-07-2007

Re: KVM Disabled

It's likely that the message is referring to the Kernel-based Virtual Machine, which you wouldn't need unless you want to run VMs that make make use of it.
This gives some adive on the error:  "KVM: disabled by BIOS" error
Community Veteran
Posts: 7,988
Thanks: 635
Fixes: 8
Registered: 02-08-2007

Re: KVM Disabled

HB,
Unfortunately that didn't do the trick, following message appeared,..........package qemu-kvm is not installed, so not removed
Community Veteran
Posts: 4,949
Thanks: 358
Fixes: 16
Registered: 10-06-2010

Re: KVM Disabled

Maybe you need to prevent the kvm kernel modules from being loaded automatically:

# echo blacklist kvm >> /etc/modprobe.d/nokvm.conf
# echo blacklist kvm-amd >> /etc/modprobe.d/nokvm.conf
# echo blacklist kvm-intel >> /etc/modprobe.d/nokvm.conf

Or just ignore the message.
Community Veteran
Posts: 6,610
Thanks: 209
Fixes: 15
Registered: 16-02-2009

Re: KVM Disabled

try
apt purge qemu
That should remove it.
Community Veteran
Posts: 7,988
Thanks: 635
Fixes: 8
Registered: 02-08-2007

Re: KVM Disabled

HB,
All I get from that is Package qemu is not installed, so not removed.
ejs,
Message I get after pasting first line in is,  bash: /etc/modprobe.d/nokvm.conf: Permission denied.
Have tried the same instruction adding sudo echo blacklist kvm >> /etc/modprobe.d/nokvm.conf
but still the same message, I thought sudo would give me any necessary permissions ? please advise
Community Veteran
Posts: 4,949
Thanks: 358
Fixes: 16
Registered: 10-06-2010

Re: KVM Disabled

Install a nice simple text editor like leafpad. Run leafpad as root, to create a text file /etc/modprobe.d/nokvm.conf containing those three lines.
blacklist kvm
blacklist kvm-amd
blacklist kvm-intel
Community Veteran
Posts: 6,610
Thanks: 209
Fixes: 15
Registered: 16-02-2009

Re: KVM Disabled

nano is already installed.
you could also try opening synaptic and typing in kvm in the search box and see what is installed.
Community Veteran
Posts: 7,988
Thanks: 635
Fixes: 8
Registered: 02-08-2007

Re: KVM Disabled

synaptic shows the following....
iPEX is network boot firmware. It supports a variety of network cards including some wireless cards (DHCP, BOOTP, and TFTP also HTTP, iscsi.)
It supports scripting.
This package contains PXE ROM's made espically to pxeboot KVM VM's.
All this is just meaningless to me, can I just uninstall it or follow ejs suggestion of using a text editor. ?
Thanks
Community Veteran
Posts: 6,610
Thanks: 209
Fixes: 15
Registered: 16-02-2009

Re: KVM Disabled

Very strange that is all that is coming up for kvm.
But go ahead and try the text file.
do a
sudo nano <file name>
nano has on screen help to allow you to save/quit etc.
Community Veteran
Posts: 7,988
Thanks: 635
Fixes: 8
Registered: 02-08-2007

Re: KVM Disabled

To add to my problems cinnamon is crashing.
What I intend to do over the next few days is reinstall everything and start from scratch.
I am convinced the problem lies within the BIOS and it's something I am or am not doing. The layout appears(at least to me) more complicated than the BIOS of earlier motherboards.
To wind me up further Windows works fine with no problems.