cancel
Showing results for 
Search instead for 
Did you mean: 

Iphone 5c will not connect to Plusnet fibrebroadband

samoddie
Newbie
Posts: 1
Registered: 01-10-2017

Iphone 5c will not connect to Plusnet fibrebroadband

Hi,

 

Be great if anyone could help me with this.  New broadband, new router.  Working well - good connection on other devices.  Newer (and I think older - ie iPhone 4) devices working fine.  My 5c will not hook up to the network.  I have looked at various pages, and done a networks reset, a full hard reset on the phone (and have "forgotten" the networks a load of times!), and been onto Plusnet, who helped me to spearate the 2.4 and 5 GHz signals from the router (and turn one off).  Each time, the signal was visible to my phone, but my phone would not connect.

My phone will connect to other wifi networks.

The plusnet guy was stumpted

I cant see what the problem is.  One blog suggested turning off location services - also no effect.

 

All this is sucking up my time,and driving me crazy.

Anyone got any ideas?

 

Sam

1 REPLY
Plusnet Help Team
Plusnet Help Team
Posts: 145
Thanks: 50
Fixes: 10
Registered: 24-04-2017

Re: Iphone 5c will not connect to Plusnet fibrebroadband

Hi Sam, sorry to hear you're having connection issues. Only from having the same problem myself I believe I know the solution. Although the tech agent you spoke to was close in resolving the problem it can be that the device is preferring and trying to connect the the 5Ghz frequency and just not getting online when doing so. I'd suggest either to forget all the networks on the iphone and then when re-connecting to make sure you are doing so to the 2.4Ghz and it should connect fine. If this fails then the solution that worked for me was logging back into the router and disabling the 5Ghz channel completely as it seems to be older apple devices and 5Ghz just not being compatible at times. I'll include the steps on how to disable the 5Ghz in the router below.


1) To connect to your Hub One, you will need to open a browser and go to 192.168.1.254 If you have any issues doing this via Wireless, we recommend trying to do it via Ethernet cable instead.

 2) You should come to a page with information about your connection, click 'Advanced Settings' at the top and it will ask you to sign in with a Password. This is located on the back of your router under 'Admin Password'

 3) Select the option for 'Wireless' followed by '5 GHz Wireless'. If you click the 'No' option on the top Wireless network enable. This will disable the 5Ghz channel and prevent any device on trying to connect to it leaving the standard 2.4Ghz frequency active. It will add a red wifi looking light onto the front of your router to show it's disabled.

Kind regards,

Ben

 Ben Devine
 Plusnet Help Team