cancel
Showing results for 
Search instead for 
Did you mean: 

Internet Explorer stops working after a few minutes...

Community Veteran
Posts: 1,112
Registered: 30-07-2007

Internet Explorer stops working after a few minutes...

Hi Folks
I have just been trying to help a pal out who has been having some browsing problems for a few days. Internet explorer 7 (on an XP box) starts producing errors after 5 to 10 minutes of browsing, as if it is no longer connected to the net.
However he is connected via a usb bb modem, messenger is still connected and asking any security program to update works fine as well, so it is just IE that is having a problem. I have checked his IE connection settings and can’t see anything out of place; Explorer is set to dial a connection whenever a connection isn’t present.
I did try to restore his PC back a few days to the point where the trouble started but unfortunately the restores were unsuccessful. My next step will probably be to uninstall explorer and then reinstall it, but I wondered if anyone here has any better ideas or can throw some light on the issue?

Thanks
16 REPLIES
Community Gaffer
Community Gaffer
Posts: 13,430
Thanks: 1,187
Fixes: 92
Registered: 04-04-2007

Re: Internet Explorer stops working after a few minutes...

Quote from: God
Explorer is set to dial a connection whenever a connection isn’t present.

I'd change that to 'Always Dial My Default Connection' TBH. Then File > Remove tick from Work Offline and hit F5.
See if that makes a difference.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

VileReynard
Seasoned Pro
Posts: 10,999
Thanks: 265
Fixes: 11
Registered: 01-09-2007

Re: Internet Explorer stops working after a few minutes...

Quote from: God
My next step will probably be to uninstall explorer and then reinstall it, but I wondered if anyone here has any better ideas or can throw some light on the issue?

The better idea idea is to use FireFox.
Ideally uninstall IE - although I believe that's more or less impossible.

Community Veteran
Posts: 14,385
Thanks: 715
Fixes: 10
Registered: 01-08-2007

Re: Internet Explorer stops working after a few minutes...

Yep, you can't really uninstall IE but can only upgrade it. Not sure about downgrading it...
As always, try wiping the temp files first. I know it shouldn't make any difference but I had a problem with youtube a while back not finding my player and thus giving me the javascript turned off message. As soon as I wiped the temps it all worked.
Have you created another user account on their PC and tried to see if the same thing happens? - Thats always my first port of call before a system restore. Thats how I nailed the youtube problem...
I need a new signature... i'm bored of the old one!
Community Veteran
Posts: 1,112
Registered: 30-07-2007

Re: Internet Explorer stops working after a few minutes...

Thanks Folks
I will give these options a try.
Community Veteran
Posts: 1,112
Registered: 30-07-2007

Re: Internet Explorer stops working after a few minutes...

Quote from: okrzynska
Yep, you can't really uninstall IE but can only upgrade it. Not sure about downgrading it...
As always, try wiping the temp files first. I know it shouldn't make any difference but I had a problem with youtube a while back not finding my player and thus giving me the javascript turned off message. As soon as I wiped the temps it all worked.
Have you created another user account on their PC and tried to see if the same thing happens? - Thats always my first port of call before a system restore. Thats how I nailed the youtube problem...


There are 4 accounts on the PC they all have the same problem.
Community Veteran
Posts: 6,735
Thanks: 12
Registered: 02-02-2008

Re: Internet Explorer stops working after a few minutes...

Have you tried a registry cleanup yet?
Midville
Grafter
Posts: 376
Registered: 05-04-2007

Re: Internet Explorer stops working after a few minutes...

I have had major problems with IE the last month or so. Constant 'lock ups / freezing' it has been really lousy!
No problems with Firefox.
minkey
Grafter
Posts: 386
Registered: 22-07-2007

Re: Internet Explorer stops working after a few minutes...

Does it crash when you run Internet Explorer in No Add-ons Mode?
Start -> Accessories -> System Tools -> Internet Explorer (no add-ons)
Jeff
Community Veteran
Posts: 1,112
Registered: 30-07-2007

Re: Internet Explorer stops working after a few minutes...

I'll check that out as well, cheers.
Midville
Grafter
Posts: 376
Registered: 05-04-2007

Re: Internet Explorer stops working after a few minutes...

Only been running it for 5 mins or so and no crashes in 'IE safe mode'.
minkey
Grafter
Posts: 386
Registered: 22-07-2007

Re: Internet Explorer stops working after a few minutes...

If safe-mode stops the crashing, you then need to identify which add-on is causing the problem.
From IE7 Select Tools - > Manage Add-ons -> Enable or Disable Add-ons.
From there its a bit trial and error. Disable each add-on in turn to see which one is causing it to crash.
Depending which add-on is causing you problems you can then choose it leave it turned off or try reinstalling the problem app.
Jeff
Community Veteran
Posts: 1,112
Registered: 30-07-2007

Re: Internet Explorer stops working after a few minutes...

Tried all of the above and no joy. Firefox would not connect either so it may well be a reinstall. I will get the machine here and try it on my router and see if that makes any difference.
Anteaus
Grafter
Posts: 64
Thanks: 1
Registered: 02-08-2007

Re: Internet Explorer stops working after a few minutes...

Quote from: God
Tried all of the above and no joy. Firefox would not connect either so it may well be a reinstall. I will get the machine here and try it on my router and see if that makes any difference.

The two key mistakes here are using Internet Explorer and a USB modem. Both are notorious for their poor security, and iffy reliability. A system set-up with an Ethernet router and Firefox will be far more stable and reliable.
First though, the cause of the problem will need to be found. It may be an issue with the USB modem, or it may be a spyware infection picked up as a 'drive-by download.' Lavasoft's Ad-Aware, from  http://www.lavasoftusa.com is one of the better spyware detectors.
Other thing is, what antivirus do you use? If it's Norton, this may be causing problems rather than curing them. A free product such as AVG or NOD32 would be far preferable.
Community Veteran
Posts: 1,112
Registered: 30-07-2007

Re: Internet Explorer stops working after a few minutes...

Forgive me but I think you are jumping to conclusions. Using internet explorer isn’t a mistake for the 80+% of people who use it daily and the vast majority use it without any problems. Personally I prefer it to any other browser I have tried.  Using a USB modem isn’t as reliable as a router for sure, but this is not the problem as he isn’t losing his connection, other programs remain connected, browsers are losing their connection.
He has run full scans with bitdefender which is fairly reliable on XP. When I get the machine here I will run several other scanners to be sure that isn’t causing a problem.