Showing results for 
Search instead for 
Did you mean: 

IKEv2 VPN Blocked by Plusnet but allowed on Sky

Posts: 1
Registered: ‎03-04-2020

IKEv2 VPN Blocked by Plusnet but allowed on Sky

In the current Covid-19 crisis we are being asked to work from home. I'm an IT worker so am used to using technology.

We use Microsoft Always On VPN client, which is configured for IKEv2. This uses UDP 500 and 4500 ports. If I try to access our VPN server it fails. If I hop onto my neighbours Sky broadband it works fine, so I know the laptop configuration works. If I change my connection to use SSTP (TCP 443) it works, but we have very limited SSTP connections available, but 1000's of IKEv2 connections.  I have enabled VPN Port Clamping, disabled the firewall and even put my laptop in the DMZ on the PlusNet One Hub, but still it gets blocked.

Why are PlusNet blocking IKEv2 when more and more VPN clients are using this protocol?

Is there anything I can request or configure to allow my IKEv2 connection?




Posts: 1,254
Thanks: 263
Fixes: 38
Registered: ‎18-10-2008

Re: IKEv2 VPN Blocked by Plusnet but allowed on Sky

fwiw, I use IKEv2 to my VPN provider with no problems with Windows 10 built-in vpn client.   My OpenWrt router reported I am using ports 500 and 4500. 


A bit of a long shot, have you disabled 'Safe Surf' firewall on your plusnet account ?

Problem could be with the Hub One.  Do you have access to another VDSL router you can try on your Plusnet connection to help narrow down the actual cause?

Note also Sky supports IPv6, is only other obvious difference between Plusnet and Sky broadband services.

ex-Plusnet (ADSL, FTTC) 2008-2023. now BT (FTTP) 2023-
Posts: 16,625
Thanks: 5,235
Fixes: 245
Registered: ‎24-02-2012

Re: IKEv2 VPN Blocked by Plusnet but allowed on Sky

@Stuart7777 In addition to @bill888 comment above, have you turned the broadband firewall (My Account>Broadband>Broadband Firewall) to 'low' - or 'off'?

Posts: 4
Registered: ‎11-03-2019

Re: IKEv2 VPN Blocked by Plusnet but allowed on Sky

I found that IKEV2 was working fine using my PlusNet home hub from around 30th August 2020 until 12th December 2020 on a daily basis. As of that day, IKEV2 VPN stopped working. It hasn't worked since then.

I manage the Draytek router in my company that offers this VPN service, and I know that nothing had changed. I regenerated certificates and re-applied the settings again, to make sure. It still didn't work for me. And it still doesn't work.

Then I happened to be setting up another machine a few days ago for a user with a BT broadband connection. I found that IKEV2 VPN still works from his house to the same router.

So the question arises again: is there any deliberate blocking of IKEV2 VPN by PlusNet? Has this changed recently?