cancel
Showing results for 
Search instead for 
Did you mean: 

I-phone and wireless network

Community Veteran
Posts: 3,826
Thanks: 44
Fixes: 1
Registered: 24-09-2008

I-phone and wireless network

My neighbours don't have Internet, they don't actually have a PC,  when they need to look something up on the internet they use my desktop.
We trust each other (we have a spare set of keys to their house, they have spare keys to our house).
We've a wireless router and tend to use it around the house and garage (we've an apartment above our garage where I have a small office). I connect using a laptop. The wireless is WEP protected, wasn't originally (a year ago), but it is now
We're in a mobile phone black spot (no mobile phone connection for couple of miles in any direction), there are no other neighbours within 500 meters.
Neighbours son was given an I-phone as a present, he can connect to our wireless network without a WEP key, is this common? (I've actually watched him do it).
I change the WEP key he can still connect, I turn off the router he cannot connect.
Any suggestions? what am I missing?
9 REPLIES
Community Veteran
Posts: 38,460
Thanks: 1,030
Fixes: 62
Registered: 15-06-2007

Re: I-phone and wireless network

I suppose the first question is - which router
Community Veteran
Posts: 3,826
Thanks: 44
Fixes: 1
Registered: 24-09-2008

Re: I-phone and wireless network

Thanks Oldjim, got me stumped, router is a Netgear DG834G.
Moderator
Moderator
Posts: 26,960
Thanks: 1,758
Fixes: 135
Registered: 14-04-2007

Re: I-phone and wireless network

I've tried it with the same kit and can't do it...clever lad.

Customer and Forum Moderator.

Community Veteran
Posts: 38,460
Thanks: 1,030
Fixes: 62
Registered: 15-06-2007

Re: I-phone and wireless network

Check the access list under Wireless Settings - is access control on and is he on the approved users list
Community Veteran
Posts: 3,826
Thanks: 44
Fixes: 1
Registered: 24-09-2008

Re: I-phone and wireless network

Thanks guys
Quote
is access control on and is he on the approved users list
will check I'm away from system at present.
Quote
clever lad
don't think so, he's a nice kid, always polite, more interested in traditional things (motor bikes, cycles, ferrets, messing around with engine parts), built himself a go-cart from an old lawn mower, think its more by luck he's managed to find a way through.
Moderator
Moderator
Posts: 26,960
Thanks: 1,758
Fixes: 135
Registered: 14-04-2007

Re: I-phone and wireless network

I'm very interested in the outcome of this thread as I have the same setup as journeys.
No matter what security setting I use on the router apart from none at all I can't get my iPhone to connect without entering a  password.
Access control doesn't by-pass the security. Undecided

Customer and Forum Moderator.

David_W
Rising Star
Posts: 2,297
Thanks: 30
Registered: 19-07-2007

Re: I-phone and wireless network

On his iPhone do you see a little padlock next to your routers name?
Community Veteran
Posts: 3,826
Thanks: 44
Fixes: 1
Registered: 24-09-2008

Re: I-phone and wireless network

@ dgwebb - No no small padlock next to his name.
Its a DG834Gv4, problem resolved this morning:-
Under Router>wireless setting>security options there is a radio button marked "disable" (currently 'off')
The radio button below is marked WEP (Wired Equivalent Privacy), currently 'on'
I switched the radio button to disabled, re-booted the router and as expected the lad could get in.
I then reswitched the radio botton to WEP and entered a new passkey, hit apply then re-booted the router, now he's locked out.
I'd guess something is not 100% correct with the firmware.  I'm running V5.01.01 although the latest firmeware version is v5.01.14.
I'll wait towards the end of the month then upgrade the firmware.
thanks all
David_W
Rising Star
Posts: 2,297
Thanks: 30
Registered: 19-07-2007

Re: I-phone and wireless network

Sorry, forgot about this one!  The little padlock sign on the iPhone means "secured connection" as in it has WPA/WEP/WMD, so because you were not seeing that it meant that yep, your wireless wasn't secure.  Glad you got it all sorted though Cheesy