cancel
Showing results for 
Search instead for 
Did you mean: 

Head scratching Toshiba time

FIXED
Minivanman
Seasoned Hero
Posts: 6,016
Thanks: 1,595
Fixes: 1
Registered: ‎04-11-2014

Head scratching Toshiba time

Just bought and installed a Toshiba external hard drive and have started to work my way through the instructions but one of the first things it tells me to do is to not plug or unplug without first clicking on the "hardware and eject media icon" and then follow those pop up messages. All fine and dandy, but where the heck is it? 

It's installed OK and I can find it on the files menu, but not desktop icon for some reason. Any clues guys? In the meantime I'll plough on through those instructions!

PS. I'm running Windows 10 for my sins.

I know where I am, I've been lost here before.
5 REPLIES
Browni
Aspiring Hero
Posts: 2,299
Thanks: 790
Fixes: 47
Registered: ‎02-03-2016

Re: Head scratching Toshiba time

Fix

It should be in the system tray next to the clock

Bottom left of this screenshot from Windows 10 on my PC after right clicking it...

2017-01-17.png

I must have been really bad in a previous life as this was my 3rd ISP in a row that used lithium.
Now you're stuck with me because my new ISP doesn't run a forum Cheesy
Community Gaffer
Community Gaffer
Posts: 3,396
Thanks: 2,197
Fixes: 78
Registered: ‎22-02-2016

Re: Head scratching Toshiba time

Its normally an icon in the system tray (bottom right of screen) that has a picture of a usb stick with a tick.

Safely-Remove-Hardware-USB-Windows-10-Icon-Missing

It might be hidden in the system tray so you will need to expand the tray by clicking the arrow to view everything else. By clicking this it should give you the option to safely remove the device before unplugging it.

The other way is to navigate the file explorer to the overview of all your hard drives and connected devices and right click on the usb drive and click 'eject'.

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

Community Gaffer
Community Gaffer
Posts: 3,396
Thanks: 2,197
Fixes: 78
Registered: ‎22-02-2016

Re: Head scratching Toshiba time

If the device is connected and you aren't getting the USB icon you will need to manually run a command to open up the 'remove hardware' dialogue.

  • Press Windows key and R at the same time. This will open Run window
  • Enter the following command into Run, and press Enter:
RunDll32.exe shell32.dll,Control_RunDLL hotplug.dll
  • This will open Safely Remove Hardware dialog, from this dialog, you can select the device you want to remove, and remove it, by clicking on Stop.

safely-remove-hardware-windows-10

source: http://windowsreport.com/safely-remove-hardware-icon-windows-10/

Note: I haven't tried this myself but I will try it out when I get home later on my Win10 PC.

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

Minivanman
Seasoned Hero
Posts: 6,016
Thanks: 1,595
Fixes: 1
Registered: ‎04-11-2014

Re: Head scratching Toshiba time

Cheers @jaread83, I'll give that a go Thumbs Up

PS.Have found that icon hidden as you said and have been able to drag and drop to the system tray. 

I know where I am, I've been lost here before.
VileReynard
All Star
Posts: 11,175
Thanks: 303
Fixes: 11
Registered: ‎01-09-2007

Re: Head scratching Toshiba time

Good thing Windows 10 is so user friendly. Crazy