cancel
Showing results for 
Search instead for 
Did you mean: 

FTP uploading…now getting nothing

Fin50
Dabbler
Posts: 12
Registered: 12-08-2016

FTP uploading…now getting nothing

Hello all and I was directed here as it seems plusnet webchat person had no idea’s as to how to fix my problems

 

Will explain as best I can (but not a tech type person )

 

I have two IP cameras (Two different makes) I have been using the free webspace given to me by plusnet to upload snap shots that the camera’s take …both have been doing this with no problems until last week. Nothing has changed in my setting’s for these cameras

 

When I click on the test setting for each camera they both say Server error ..I use filezilla and can see the directories for both cameras, I can even upload to these using filezilla …but not one snapshot is being uploaded

 

I have rebooted both cameras ..still nothing …nothing is ain the webspace so plenty of space there

 

Any idea as to what it could be ?

 

Thank you

30 REPLIES
VileReynard
Seasoned Pro
Posts: 10,825
Thanks: 250
Fixes: 10
Registered: 01-09-2007

Re: FTP uploading…now getting nothing

Do the cameras upload to your PC which then uploads to the webspace, or;

do the cameras upload directly to the webspace?

Could it be a DHCP problem where the cameras change ip address - or the external router ip address changes.

 

I've come across a rather nice speed test which doesn't use Flash or Java and shows your WAN address. http://speedof.me/

Fin50
Dabbler
Posts: 12
Registered: 12-08-2016

Re: FTP uploading…now getting nothing

Cameras upload directly to ftp , the router has a fixed ip address 

 

And tried another site to upload images from camera, everything worked as it should, so nothing wrong with the camera. I can only conclude that the server for plus net is blocking uploading from the camera

Fin50
Dabbler
Posts: 12
Registered: 12-08-2016

Re: FTP uploading…now getting nothing

I presume no one has had any similar problems than? or any ideas as to what the problem might be ?

 

I will try calling plusnet and see if I can get a response, was easier when you raised a ticket with a problem. Now it seems they only have web chat and they then just direct you here

Community Veteran
Posts: 3,274
Thanks: 339
Fixes: 12
Registered: 24-10-2013

Re: FTP uploading…now getting nothing

the fact that you can upload to ftp using normal ftp clients suggests there is nothing wrong with the plusnet supplied ftp.
it's unlikely that plusnet will be able to, or willing to, offer any support for your camera issue.
Fin50
Dabbler
Posts: 12
Registered: 12-08-2016

Re: FTP uploading…now getting nothing

How is it a camera issue? I am now using another hosting site and images are being uploaded correctly, when I enter the plusnet details and then try test setting, I then get a message on both cameras saying server error...now I may be thick but that would suggest that something is wrong on the plusnet server side of things. Nothing had changed since I set up the cameras, they uploaded images with no issues, then one day it stopped, no setting had been changed on them...I still have plenty of space on the webspace

 

I would suggest that plusnet is somehow blocking uploads from the cameras

VileReynard
Seasoned Pro
Posts: 10,825
Thanks: 250
Fixes: 10
Registered: 01-09-2007

Re: FTP uploading…now getting nothing

Do the cameras provide Plusnet with the proper account user/password credentials?

You should get a 3 digit error code, if something is wrong - what do you get?

Fin50
Dabbler
Posts: 12
Registered: 12-08-2016

Re: FTP uploading…now getting nothing

The cameras have the correct details, always have had. I can go to the parent directory and can see that when I log into filezilla. I get no error codes but where exactly would I be give  these Codes?

 

Everything is there on my we space,  the htdocs folder is there, the sub folders within for the cameras that files did get uploaded to...I can use filezilla to upload to these sub folders. I used another free site to upload images direct to test camera and both did that to this free site... so nothing is wrong with them

 

Have rebooted both inserted the setting for plus net ...ftp.plus.net.....port 21....my username and password ftp upload folder htdocs/camera.......and nothing uploads.....do it again for the free webs pace and both upload any alarm triggered images

 

 

So I can only conclude that plus net has somehow blocked the isp camera from uploading or something like that

Superuser
Superuser
Posts: 9,514
Thanks: 868
Fixes: 53
Registered: 06-04-2007

Re: FTP uploading…now getting nothing

Are the cameras attempting to use active or passive FTP to communicate with the server.

David
VileReynard
Seasoned Pro
Posts: 10,825
Thanks: 250
Fixes: 10
Registered: 01-09-2007

Re: FTP uploading…now getting nothing

Have you changed your Plusnet password recently?

Community Veteran
Posts: 4,846
Thanks: 121
Fixes: 24
Registered: 14-07-2009

Re: FTP uploading…now getting nothing

Have you reached the capacity allowance of your web space?

Community Veteran
Posts: 5,237
Thanks: 1,321
Fixes: 31
Registered: 16-10-2014

Re: FTP uploading…now getting nothing

@Fin50 - I don’t think the cameras are blocked because as far as the FTP site is concerned the address accessing the FTP server is your router’s public IP address. You said that this address is fixed so you have paid for a static IP from Plusnet?

Also, have you checked this address just to double check that it’s not changed? According to your test you can upload to another free service but does this service work in the same way as the Plusnet FTP? By that I mean does the Plusnet FTP need to know who and who cannot connect.

Have you checked the access logs on your server, they should give you a clue as to what is happening. Where they are for Plusnet I don’t know, but someone here will.

From a desktop PC can you FTP a file up to Plusnet? If not then I’d check your FTP servers configuration to make sure that not been changed.

VileReynard
Seasoned Pro
Posts: 10,825
Thanks: 250
Fixes: 10
Registered: 01-09-2007

Re: FTP uploading…now getting nothing

You have two directories:  /htdocs & /logs which contains files with names like www.username.plus.com.gz

This compressed file contains lines like 179.38.68.9 - - [20/Aug/2016:00:42:10 +0100] "GET /images/dripping_blood.gif HTTP/1.1" 200 5128 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0" www.[redacted].plus.com

But these are web logs - not FTP logs.

If you want FTP logs, you could try a command entry line.

Example of a deliberately bad connection (bad username & password) :-

jeremy@hector ~ $ ftp www.username.plus.com
Connected to homepages.plus.net.
220-PLEASE NOTE: If you have a non-subscription account you
will only be able to login to this ftp server if you are
dialled into our network.

A Maximum of 4 concurrent connections are allowed to this
server, each session is limited to 256KB/s downloads.

220 Plus.Net FTP Server #1 ready
Name (www.username.plus.com:jeremy): jeremy
331 Password required for jeremy
Password:
530 Login incorrect.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> quit
221 Goodbye.

Fin50
Dabbler
Posts: 12
Registered: 12-08-2016

Re: FTP uploading…now getting nothing

Sorry but I have no idea what all that means, I can follow directions, but I have not got a clue how or where you do any of that

 

But thanks

Superuser
Superuser
Posts: 9,514
Thanks: 868
Fixes: 53
Registered: 06-04-2007

Re: FTP uploading…now getting nothing

Does that reply apply to each of messages 9 to 13 which have been posted since your previous response?

David