cancel
Showing results for 
Search instead for 
Did you mean: 

Email Problem.....

Community Veteran
Posts: 17,760
Thanks: 1,601
Fixes: 19
Registered: 06-11-2007

Email Problem.....

I am (and have been) using Thunderbird, as my email for quite a long time,..... just recently, I have been getting the following message, even when I use the "reply to sender" format....
I know the email addresses are correct, as I have tried sending one to my blogsite email address for confirmation
An error occurred while sending email. The mail server responded:
Relay not permitted. Please check the message recipient
enquiries (at) nemosphotography.co.uk  and try again....
can someone please advise me what to look for, and where, in my settings, has something changed.....?  without me knowing?  (I don`t recall doing any settings changes, since I first set up the email on this new hdd)....
cheers
28 REPLIES
hadden
Grafter
Posts: 486
Thanks: 2
Registered: 27-07-2007

Re: Email Problem.....

Could I suggest that you check that the default STMP server settings are OK?
Tools -> Account Settings -> Outgoing Server -> Edit...
If you always send email when using a Plusnet internet connection then this should be relay.plus.net and port 25.
If you sometimes connect other than via a Plusnet internet connection then the server should relate to that ISP when connected that way, otherwise you can get the error that you are finding, on those occasions.
Community Veteran
Posts: 17,760
Thanks: 1,601
Fixes: 19
Registered: 06-11-2007

Re: Email Problem.....

At present I am connected via wireless, via my son`s connection, (tiscali I think) ..... but I would have thought that I could send emails from "any connection".  or am I thinking wrong here?
I do not use webmail...... my email is through the normal Thunderbird system....
pierre_pierre
Grafter
Posts: 19,757
Registered: 30-07-2007

Re: Email Problem.....

You can normally do that, but some ISP's block others, not come across one my self, done it from many places in the UK with no problem using the normal Thunderbird settings.  Oban, Sky, Eden, Fowey, Cardigan, And Eire and Bury St Edmunds on Tiscalli
itsme
Grafter
Posts: 5,924
Thanks: 1
Registered: 07-04-2007

Re: Email Problem.....

You can receive emails using any connections but sendings is a completely different matter. Some providers will completely block SMTP other then their own servers. But the problem you are encountering is that you need to use SMTP authentication. Not sure where you will find this in Thunderbird but should be in the area where you enter the SMTP setting. The username and password will always be you main PN email account for all mailboxes.
PN did not use to support SMTP authenciation but I believe they do now.
pierre_pierre
Grafter
Posts: 19,757
Registered: 30-07-2007

Re: Email Problem.....

this is my Thunderbird setting that works
Community Veteran
Posts: 14,381
Thanks: 713
Fixes: 10
Registered: 01-08-2007

Re: Email Problem.....

Quote from: shutter
The mail server responded:
Relay not permitted. Please check the message recipient
enquiries (at) nemosphotography.co.uk  and try again....

Quote from: shutter
At present I am connected via wireless, via my son`s connection, (tiscali I think).

Quote from: pierre_pierre
You can normally do that, but some ISP's block others, not come across one my self

I have and they're a pain in the backside Sad
@shutter: Setting authentication is probably not going to make much difference although admittedly most times you don't useit on your ISP connection as it automatically detects you from the connection anyway. Is that email address in the error from the recipients server or the server you are using as a SMTP server? - If you're using it as a smtp server then you need to contact the address specified as the rest of us here are poking at shadows.
I need a new signature... i'm bored of the old one!
Community Veteran
Posts: 17,760
Thanks: 1,601
Fixes: 19
Registered: 06-11-2007

Re: Email Problem.....

That particular example of email address "enquiries (at) ......." is my own email contact address from my website. but it gives the same response when I click the "send" button, as to other email addresses, even if I use the "reply to sender" (to ensure I get the address correct)... so assume it must be something to do with the Tiscali setup, not accepting mail from me...
No big deal at the moment, as I am going home tomorrow, but could present problems in the future, if I am away for a couple of weeks, and cannot send emails..... so need to find out why it (presumably Thunderbird) is refusing to send them....
I haven`t got windows mail set up at the moment, so cannot check it against Thunderbird... (and of course when I get home, I hope I will not have any problems, sending from my own router)
Superuser
Superuser
Posts: 6,772
Thanks: 851
Fixes: 54
Registered: 30-07-2007

Re: Email Problem.....

I'm pretty sure itsme identified your problem earlier.
Quote
But the problem you are encountering is that you need to use SMTP authentication. Not sure where you will find this in Thunderbird but should be in the area where you enter the SMTP setting. The username and password will always be you main PN email account for all mailboxes.

If you are not connected to the Plusnet network then you will not be able to send mail using their SMTP server without authenticating.
On the Thunderbird SMTP Configuration dialog box as shown by pierre, check the 'Use name and password' box and enter your main plusnet username ( the one use use on your router or to access the plus.net portal ), leave the Use Secure connection set to 'No' and then click ok. Next time you try to send mail it should ask for your password ( as above, the one you use on the router or portal ), probably with an option to save it for future use.
BTW you get to the SMTP configuration from Edit->Account Settings->Outgoing server, then select the server in the list and click 'edit'.
Edit:- this should work when connected to most other ISP networks although some, as okrzynska says, do block port 25 to anything other than their own smtp server. In this case the only way to send ( other than by using webmail ) is to use the smtp server for the network you are connected to. e'g for 3 mobile bb use smtp-mbb.three.co.uk. You can add additional smtp servers to Thunderbird and then select which you wish to use when sending but its a bit of a pain.
itsme
Grafter
Posts: 5,924
Thanks: 1
Registered: 07-04-2007

Re: Email Problem.....

Quote from: shutter
That particular example of email address "enquiries (at) ......." is my own email contact address from my website. but it gives the same response when I click the "send" button, as to other email addresses, even if I use the "reply to sender" (to ensure I get the address correct)... so assume it must be something to do with the Tiscali setup, not accepting mail from me...

If you are using relay.plus.net as the SMTP server then the relaying message you are seeing is from PN because you are not using a PN BB connection to send and not using SMTP authentication.

Quote from: okrzynska

@shutter: Setting authentication is probably not going to make much difference although admittedly most times you don't useit on your ISP connection as it automatically detects you from the connection anyway. Is that email address in the error from the recipients server or the server you are using as a SMTP server? - If you're using it as a smtp server then you need to contact the address specified as the rest of us here are poking at shadows.

Not sure what you mean by automatically detects you from the connection anyway. The error message is from the SMTP server as it's say 'relaying is not permitted. This message is seen if PN relay server is used from a non-PN broadband connection and not using SMTP authentication.
pierre_pierre
Grafter
Posts: 19,757
Registered: 30-07-2007

Re: Email Problem.....

I have definitely sent e-mails via Thunderbird from my Sister in Bury St Edmunds, who is on Tiscalli using the set up as above
Community Veteran
Posts: 17,760
Thanks: 1,601
Fixes: 19
Registered: 06-11-2007

Re: Email Problem.....

First Prize to MisterW..... thanks very much for the instructions..... got a test message through to my enquiries@ address, and returned through plusnet email re-direct to my proper address. so am well pleased...  Presumably, when I get home, I will not need to keep putting in my password when I send email, as PN will know I am back on my normal connection ?
Happy New Year to all.    Wink    Cheesy  
itsme
Grafter
Posts: 5,924
Thanks: 1
Registered: 07-04-2007

Re: Email Problem.....

@pierre
The only thing that concern me using relay.free-online.net is that it does not use authentication and therefore is an open relay and can be abused by spammers and placed on a blacklist.
Superuser
Superuser
Posts: 6,772
Thanks: 851
Fixes: 54
Registered: 30-07-2007

Re: Email Problem.....

Well it was itsme really, I just filled in the blanks for Thunderbird since I use it in exactly this way ( albeit on Linux! ).
Quote
Presumably, when I get home, I will not need to keep putting in my password when I send email, as PN will know I am back on my normal connection ?

If when you entered the password you checked the save/remember password then it should not ask you for it again. When you are back on your normal Plusnet connection you could just go back into the SMTP settings and uncheck the 'use name and password' as you will not need to authenticate. There is no problem with leaving it checked other than each time you send an email your userid & password are sent ( unencrypted ).
Edit :- sorry pierre didnt realise your settings used a free relay but as itsme says its open to being blacklisted. If you need to send mail reliably from lots of networks there are subscription services such as smtpauth.com which provide authenticated servers which can be used from anywhere. They even provide servers other than on port 25 to avoid the problems with blocking of that port by some ISP's
pierre_pierre
Grafter
Posts: 19,757
Registered: 30-07-2007

Re: Email Problem.....

OK, but if PN dont require authentification, and I am changing the setting at the sender end, what difference does that make, if the spammer wants to do it, the change should be at the PN end, so that all senders will have to use it, or am I missing something?  PS  Free-online is PN