cancel
Showing results for 
Search instead for 
Did you mean: 

Dongle 2: Windows keeps reinstalling it when plugging in..

Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Dongle 2: Windows keeps reinstalling it when plugging in..

Hi again all
Right.. My 3G dongle works. Brilliantly infact..
The software is installed, all works fine, I've got the USB autorun thing working again (Thankyou VMWare for messing up my desktop PC so much) and basically once plugged in, installed, installed again, disconnected, installed etc, the dongle works and connects flawlessly.
My problem however is indicated above.
I plug it in, and the windows hardware wizard and balloon thing on the task tray kick in - It recognises all sorts of daft things. Then disconnects it, and then recognises and installs them all again. I would expect this using a different usb socket but not when I'm using the same one continually.
It does not do this on my netbook so I'm finding it very annoying that it does it on my desktop. It's as if Windows can't actually remember what the device is. Once its finished re-recognising and installing the hardware the existing 3Connect software already installed on the PC kicks in perfectly.
Dongle is still very usable but its just annoying me that Windows is playing up so much.
Any ideas?
I need a new signature... i'm bored of the old one!
6 REPLIES
Superuser
Superuser
Posts: 6,472
Thanks: 590
Fixes: 49
Registered: 30-07-2007

Re: Dongle 2: Windows keeps reinstalling it when plugging in..

Most 3g USB dongles actually appear as 2 different devices. When they are initially plugged in then it appears as a virtual CD device , this allows the onboard software ( drivers and utilities ) to be installed. If the drivers are already installed then the dongle is 'switched' by the driver into modem mode, it disconnects from the USB and then is redetected as a modem. That might explain why Windows appears to make such a 'meal' of it, although it doesn't explain why your Netbook is different.
It is possible with some dongles ( the ZTE ones for instance ) to disable the virtual CD mode by sending it a AT+ZCDRUN=8 command ( you can reenable it with AT+ZCDRUN=9 ) See here for example http://3g-modem.wetpaint.com/page/ZTE+K3565-Z+%28Vodafone%29.
With the CD mode disabled you wouldn't be able to install the software on another PC by inserting the dongle but it will work fine on any PC with already has the drivers installed. I use my ZTE MF627 in this way on all my Linux boxes since the software on the virtual CD is Windows only.
Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Re: Dongle 2: Windows keeps reinstalling it when plugging in..

Hi MW
I start by plugging my dongle in and then at the tray it will detect in the following sequence:

  • USB Composite Device

  • HUAWEI Mobile

  • USB Mass Storage Device

  • HUAWEI Mobile (again)

  • USB Mass Storage Device (again)

  • HUAWEI Mass Storage USB Device

  • CD-Rom Drive

  • HUAWEI MMC Storage USB Device

  • Disk Drive

  • [USB Disconnection Sound] A Problem occurred during hardware installation. Your new hardware might no work properly

  • [15 seconds later approx]USB Connection sound

  • HUAWEI Mass Storage USB Device (again)

  • CD-Rom Drive (again)

  • Your new hardware is installed and ready to use


If I then unplug after a minute or so and plug it in again to the very same socket, it does the whole thing again - and if I use any other socket too.
This doesn't happen on my netbook and it never used to happen on this computer pre-Windows-Reinstall until VMWare came onboard. Now I've uninstalled VMWare it has let me install it but it won't remember the device and thinks it must recognise it every time.
I've got the whole thing on video in .mov format but its 130Mb... Does youtube do .mov as I'll upload it..
It's driving me mad..
I need a new signature... i'm bored of the old one!
Superuser
Superuser
Posts: 6,472
Thanks: 590
Fixes: 49
Registered: 30-07-2007

Re: Dongle 2: Windows keeps reinstalling it when plugging in..

Hmm!. it does sound like something that VMWare has upset. I'm not too familiar with VMWare ( I use VirtualBox ) but doesn't it replace the standard Windows usb-root-hub driver with its own. Could it be the uninstall hasn't rolled back the driver properly to the Windows one ?
Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Re: Dongle 2: Windows keeps reinstalling it when plugging in..

I don't think its a driver issue to be honest. I think its more to do with the Windows hardware discovery mechanism and the way it remembers the device. Once unplugged Winblows seems to totally forget the device has ever been plugged in.
I need a new signature... i'm bored of the old one!
Superuser
Superuser
Posts: 6,472
Thanks: 590
Fixes: 49
Registered: 30-07-2007

Re: Dongle 2: Windows keeps reinstalling it when plugging in..

Yes, I'm sure its not a driver issue with regards to the dongle drivers, but if VMWare has replaced the usb-root-hub drivers then that could be affecting Windows remembering the device. Given that it works ok on the Netbook, it would point towards something that VMWare has done.
Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Re: Dongle 2: Windows keeps reinstalling it when plugging in..

Yes I think you may be right. I've spent all last night googling and found nothing of any relevance (although I found a cool little app to fix autorun problems).
I think I'll be reinstalling the OS soon Wink
I need a new signature... i'm bored of the old one!