cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco 837 will not allow uploads/mail attachments

Xenstar
Newbie
Posts: 7
Registered: ‎13-07-2008

Cisco 837 will not allow uploads/mail attachments

Hi
I have a Cisco 837 which I want to use with my Plusnet DSL connection.
It works fine for downloads, but it will not upload anything over about 20Kb. This means I can send normal email via SMTP, but emails with attachments time out. It also prevents FTP uploads and uploading of attachments to webmail.
I really can't see why this is happening. I have been through the config many times. I did wonder if it was an MTU issue, so I have set to 1458 on the router and my PC, but it makes no difference to the problem.
Interestingly, this problems occurs on both Windows and Linux, but if I switch back to my old Netgear router I don't have the issue, so it seems unlikely to be an OS issue.
Any ideas would be much appreciated to prevent me banging my head against the wall!!
My config is :

version 12.3
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname C837
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret <removed>
!
aaa new-model
!
!
aaa authentication login local_authen local
aaa authorization exec local_author local
aaa session-id common
!
resource manager
!
clock timezone PCTime 0
clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
ip subnet-zero
no ip source-route
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.60.254
ip dhcp excluded-address 192.168.60.1 192.168.60.2
!
ip dhcp pool sdm-pool
  import all
  network 192.168.60.0 255.255.255.0
  default-router 192.168.60.254
  dns-server 212.159.13.49 212.159.13.50
  lease 0 2
!
!
ip tcp synwait-time 10
ip cef
ip name-server 212.159.13.49
ip name-server 212.159.13.50
no ip bootp server
ip inspect name DEFAULT100 cuseeme
ip inspect name DEFAULT100 ftp
ip inspect name DEFAULT100 icmp
ip inspect name DEFAULT100 netshow
ip inspect name DEFAULT100 rcmd
ip inspect name DEFAULT100 realaudio
ip inspect name DEFAULT100 rtsp
ip inspect name DEFAULT100 sqlnet
ip inspect name DEFAULT100 streamworks
ip inspect name DEFAULT100 tftp
ip inspect name DEFAULT100 tcp
ip inspect name DEFAULT100 udp
ip inspect name DEFAULT100 vdolive
ip inspect name DEFAULT100 fragment maximum 256 timeout 1
no ip ips deny-action ips-interface
ip ssh time-out 60
ip ssh authentication-retries 2
!
no ftp-server write-enable
!
username admin privilege 15 secret <removed>
!
!
!
!
!
interface Null0
no ip unreachables
!
interface Ethernet0
ip address 192.168.60.254 255.255.255.0
ip access-group 100 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1418
hold-queue 100 out
!
interface Ethernet2
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
shutdown
hold-queue 100 out
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$
no ip redirects
no ip unreachables
no ip proxy-arp
pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
mtu 1458
ip address negotiated
ip access-group 101 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip inspect DEFAULT100 out
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname <removed>@plusdsl.net
ppp chap password 7 <removed>
ppp pap sent-username <removed>@plusdsl.net password <removed>
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 1
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 102 interface Dialer0 overload
ip nat inside source static tcp 192.168.60.2 3784 interface Dialer0 3784
ip nat inside source static udp 192.168.60.2 3784 interface Dialer0 3784
!
logging trap debugging
access-list 1 remark HTTP Access-class list
access-list 1 permit 192.168.60.0 0.0.0.255
access-list 1 deny  any
access-list 100 deny  ip host 255.255.255.255 any
access-list 100 deny  ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 permit udp host 194.238.48.3 eq ntp any eq ntp
access-list 101 remark Ventrilo UDP
access-list 101 permit udp any any eq 3784 log
access-list 101 remark Ventrilo TCP
access-list 101 permit tcp any any eq 3784 log
access-list 101 deny  ip 192.168.60.0 0.0.0.255 any
access-list 101 permit icmp any any echo-reply
access-list 101 permit icmp any any time-exceeded
access-list 101 permit icmp any any unreachable
access-list 101 deny  ip 10.0.0.0 0.255.255.255 any
access-list 101 deny  ip 172.16.0.0 0.15.255.255 any
access-list 101 deny  ip 192.168.0.0 0.0.255.255 any
access-list 101 deny  ip 127.0.0.0 0.255.255.255 any
access-list 101 deny  ip host 255.255.255.255 any
access-list 101 deny  ip host 0.0.0.0 any
access-list 101 deny  ip any any
access-list 102 permit ip 192.168.60.0 0.0.0.255 any
access-list 103 permit ip 192.168.60.0 0.0.0.255 any
access-list 103 deny  ip any any
dialer-list 1 protocol ip permit
no cdp run
!
!
control-plane
!
banner login ^C
*******************************
* Private System              *
*******************************
^C
!
line con 0
login authentication local_authen
no modem enable
transport preferred all
transport output telnet
line aux 0
login authentication local_authen
transport preferred all
transport output telnet
line vty 0 4
access-class 103 in
authorization exec local_author
login authentication local_authen
transport preferred all
transport input telnet ssh
transport output all
!
scheduler max-task-time 5000
scheduler interval 500
ntp clock-period 17179537
ntp server 194.238.48.3 source ATM0.1
ntp server 194.238.48.3 source Dialer0 prefer
end
3 REPLIES 3
samuria
Grafter
Posts: 1,581
Thanks: 3
Registered: ‎13-04-2007

Re: Cisco 837 will not allow uploads/mail attachments

Have you tried
ip inspect name DEFAULT100 smtp
Xenstar
Newbie
Posts: 7
Registered: ‎13-07-2008

Re: Cisco 837 will not allow uploads/mail attachments

Yes I used to have an inspect SMTP. I removed it in case it was causing this issue.
It's also worth noting this appears to be all uploads above about 32kb, not just SMTP, but FTP, http, etc.
Very puzzling
Xenstar
Newbie
Posts: 7
Registered: ‎13-07-2008

Re: Cisco 837 will not allow uploads/mail attachments

Just a final update to this post to say I have now resolved the issue.
I upgraded the IOS version from 12.3 to 12.4 (after a large amount of trial and error with ACLs) and it now works perfectly.
If others see this problem, upgrade your IOS ftw