cancel
Showing results for 
Search instead for 
Did you mean: 

Chkdsk on start-up

paulgul
Rising Star
Posts: 605
Fixes: 1
Registered: 05-04-2007

Chkdsk on start-up

Yesterday we had a short power glitch, enough to shut the computer down whilst it was in full swing. Since then every time I start up, before windows (XP with sp2) finishes loading, the chkdsk utility starts up and scans 2 out of the 4 hard drives. It doesn't seem to find any problems and all the files seem intact (the drives concerned do not contain the OS or any applications). The only other reference to the problem is if I try to defrag the drives (Diskeeper Cool I get a message saying that chkdsk is scheduled to run at the next startup and its unable to defrag the drive.
I have now restarted the computer half a dozen times and chkdsk still appears and I always allow it to do its full check cycle.
Any suggestions of how I might solve this problem?
Paul
2 REPLIES
paulgul
Rising Star
Posts: 605
Fixes: 1
Registered: 05-04-2007

Re: Chkdsk on start-up

Community Veteran
Posts: 1,571
Thanks: 3
Registered: 13-04-2007

Re: Chkdsk on start-up

what you need is
1.Edit: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
2.Change the BootExecute entry from:
autocheck autochk * /.........
To:
autocheck autochk *
If you have scheduled CHKDSK for multiple volumes, there will be an autocheck entry for each volume. Delete the string from the BootExecute registry value for each volume you do not want checked. If you have NT 4.0, SP2, a new command line utility, CHKNTFS, will assist in preventing repeated CHKDSKs during reboots if the "dirty" bit is set. Type CHKNTFS /? and see KB article Q160963.