Showing results for 
Search instead for 
Did you mean: 

Can't remote access CCTV NVR

Posts: 2
Fixes: 1
Registered: ‎22-10-2019

Can't remote access CCTV NVR

Hi all.

I'm trying to help a friend out as he wishes to remote connect into his Hikvision NVR. I've set up an identical system at my house using a TP-Link VR900 which worked straight away, but his Plusnet router doesn't seem to be playing ball.

So far in Advanced Settings I have created 3 applications

CCTV80 Ports 80-80 converted to 80-80 Both TCP and UDP

CCTV554 Ports 554-554 converted to 554-554 Both TCP and UDP

CCTV8000 Ports 8000-8000 converted to 8000-8000 Both TCP and UDP


Port 80 is the NVR web GUI

Port 554 is for rtsp streaming which is probably not needed

Port 8000 is for the mobile Hik-Connect app to connect to the NVR


I have then set the firewall to pass all these 3 applications on to the NVR which has a static internal IP. I selected the NVR from the drop down box rather than inputting the internal IP, but it does show up with the correct mac and IP in the network tree, so I have no reason to suspect this is the issue.


The connection to the property has a static IP, so I have then tried connecting to the static IP, but all I get is "This site cannot be reached".

The NVR can be viewed using the Hik-Connect app, and the IP for the device listed on the Hik-Connect website matches the one I am using.

I'm not sure what to try next.

Anyone have an idea where I'm going wrong?



Moderator's note by Dick (Strat): Post released from Spam Filter and moved to Tech Help.

Posts: 1,339
Thanks: 83
Fixes: 13
Registered: ‎04-11-2011

Re: Can't remote access CCTV NVR

First thing to check, the Plusnet broadband firewall is set to off or the advanced option to have http(s) traffic allowed through.
The place to look is in the members centre, broadband section of your friend’s account.
That's RPM to you!!
Posts: 2
Fixes: 1
Registered: ‎22-10-2019

Re: Can't remote access CCTV NVR

If anyone else has this issue, the solution was to manually enter the IP address instead of choosing the device in the drop down list. The option to do that is at the bottom of the list of devices.