cancel
Showing results for 
Search instead for 
Did you mean: 

Cache problem?

FIXED
Hooked
Posts: 9
Thanks: 1
Fixes: 1
Registered: ‎10-09-2017

Cache problem?

I'm currently working on a web site deployed onto a hosting provider.

My problem is that when I deploy chages to that site I can't always see them whe I browse to the site.

I do all my chages locally and test them locally.

I then deploy them to a GIT Hub repo for testing again and this works.

When I deploy them to my hosting provider I don't see the updates every time.

I have tried several machines, PC, Laptop and mobile; cleared browser cache and flushed dns; Rebooted PC and router. Still get the same result locally.

Other people can see my updates straight away (My hosting provider has tested with me as have people on another forum. I am the only one (that I know of) that has the problem and it is hampering my site development as I have to take time out to make sure my changes are working before moving on to the next stage.

If I turn wi-fi off on my mobile and browse over mobile data I get the updates after clearing browser cache.

Also, I can open the remote file on the hosting server and see the updated css fine. So I know my code is getting deployed properly. Browsing to the hosted site and inspecting element I don't see the relevant css updates in the code that reaches my browser.

So, it is definitely an issue with my plusnet connection (Having reset/rebooted everything on my LAN I think I can discount my local kit??)

The site can be seen at:

https://crwebservices.co.uk

and the GITHub version at:

https://cliver1956.github.io/crwebservices/

The third section on the index page "Technologies" is where the update I'm not seeing is. The header text should be grey and centered.

I suspect you will all see it but I see it in the GitHub version but not on the live version.

It has been like this a few times and, in this instance has been like it since yesterday.

Have I missed something in my local environment?

Or is this a plusnet cache problem and is there any way around it?

Many thanks for any help.

1 REPLY 1
Hooked
Posts: 9
Thanks: 1
Fixes: 1
Registered: ‎10-09-2017

Re: Cache problem?

Fix

Just figured it out.

The hosting company uses cloudflare cdn.

I had to logon to cloudflare and clear the cache there.

All now working fine Smiley