cancel
Showing results for 
Search instead for 
Did you mean: 

Bodhilinux on rooted Nexus7

edc
Newbie
Posts: 4
Registered: 30-09-2014

Bodhilinux on rooted Nexus7

I use Plusnet as my server. I have no difficulty connecting and browsing the web using Midori /Bodhi 2.4.0 on my Laptop (wired or wirelessly) but on my rooted Nexus7 on which I have installed Bodhi, after searching for the hidden connection and providing the SSID and password (security key) I am able to connect but any URL request results in the error "Cannot resolve proxy hostname ()". The Network Manager does not appear to offer a solution.
I would be grateful for any advice. NB. I am of course using the "Mobile" configuration on the Nexus; it seems to be the only one available to me

I have installed Bodhi-Linux 2.4.0 on a partition of my Dell laptop and have no difficulty in connecting to Plusnet either by wire or wireless and can browse the internet using Bodhi's preferred browser, Midori, Hence I can be sure there is no incompatibility between Bodhi and Plusnet.
I have also installed Bodhi on my rooted Nexus7 and having specified the SSID (PlusnetWireless0F8766) and the router key (**********) requested under WPA2 in the Wcid Network Manager I am able to connect to Plusnet. However when I try to browse the inernet I get the error message: " Cannot resolve proxy hostname () ".
I would be grateful for any advice.
N.B. Under WPA2 the Network manager also offers "Use static IPs " (requesting IP, Netmask and Gateway and also offers "Use static DNS" (requesting DNS Domain and DNS servers 1,2 and 3). I don't know if this is helpful but if so I would need advice regarding the entries.
The Manager also offers to set up under WPA-LEAP (requesting Username and Password) or WPA2-PEAP (requesting Username, Domain and Password). Again I don't know whether this is helpful but would require advice about entries.
There are also other non-WPA security settings offered but I feel they are not relevant.
6 REPLIES
Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: Bodhilinux on rooted Nexus7

Check your /etc/resolv.conf is pointing at 192.168.1.254 and open a terminal and see if you can ping anything, then check the proxy settings etc.
edc
Newbie
Posts: 4
Registered: 30-09-2014

Re: Bodhilinux on rooted Nexus7

Thank you.  N.B. I normally use Mint 17 and am currently doing so.
resolv.conf shows:
domain lan
search lan
nameserver 192.168.1.254
I am able to ping plus.net and google.com
I do not know how to check "the proxy settings etc",  Can you guide me,please?
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: 26-11-2012

Re: Bodhilinux on rooted Nexus7

Sounds like the browser is trying to use an http proxy - Are there any settings in the app or possibly in the network manager for this?
Just found this:
http://www.brian-gordon.name/portfolio/tw/#network
What is the Proxy server set to?  Is 'None' an option?  If not, does the setting give you a clue where to look?
Also see this:
https://wiki.archlinux.org/index.php/Proxy_settings
edc
Newbie
Posts: 4
Registered: 30-09-2014

Re: Bodhilinux on rooted Nexus7

P Watson  Thank you.
In my submission, I described fully the contents of the Wcid Network Manager provided by the installation on the Nexus7, which is very different from the Manager I see on my laptop. There is no reference to a proxy..
Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: Bodhilinux on rooted Nexus7

The proxy is either set globally using the network manager or in the case of browsers in the config for each browser.
Open your browser and check its config there will be something about http proxy server in there somewhere.
edc
Newbie
Posts: 4
Registered: 30-09-2014

Re: Bodhilinux on rooted Nexus7

Problem solved Cheesy
Under i/preferences/network  there is a "No proxy server" option and that does the trick.  Why this was not the default settings is beyond me. Thank you again for your wery clear advice.