cancel
Showing results for 
Search instead for 
Did you mean: 

Router Configuration for Internet (Multicast) Channels

Community Veteran
Posts: 3,424
Thanks: 19
Registered: ‎18-01-2013

Re: Multicast config for alternative routers

I've got a spare openwrt compatible router as well so can always have a play.
GE90
Grafter
Posts: 34
Registered: ‎12-08-2013

Re: Multicast config for alternative routers

Has anyone successfully set this up with an Apple Airport Router?
Many thanks
DougMa
Grafter
Posts: 115
Thanks: 3
Registered: ‎09-09-2011

Re: Multicast config for alternative routers

Fritz!Box 7390 as a combined VDSL2 modem/router: no luck out-of-the-box.  Sad
I cannot see any multicast options in the GUI, but a configuration backup indicates support for IGMP:
Quote
...
                ipbridgeing = no;
                ipbridgeing_igmp = no;
...
mrouter {
        igmp_version_for_upstream = 3;
        igmp_version_for_other = 3;
        igmp_prio = 48;
}
...

My first step is to test using the Technicolor, to confirm that everything else is working as expected, then I'll hand-edit the Fritz configuration and see if I can get it working.  Either way, I'll raise a case to AVM support asking if they could include this as an GUI option in a future release.
Doug.
DougMa
Grafter
Posts: 115
Thanks: 3
Registered: ‎09-09-2011

Re: Multicast config for alternative routers

Still no luck with the Fritz.  I can see the channels in the guide but get the error IPC-6023.
The Fritz has a web interface to run a packet capture (http://fritz.box/login.lua?page=/capture.lua&sid=0000000000000000), so I kicked-off a capture just before trying to switch to SyFy.  I'm seeing an IGMPv3 group join request for 234.81.130.4 leave the WAN interface on my router, but I never see any traffic received targeting that address.  I can see all the other traffic coming-and-going.
I'll try the Technicolor tomorrow.
Doug
jimbof
Grafter
Posts: 348
Thanks: 2
Registered: ‎02-05-2013

Re: Multicast config for alternative routers

What WAN traffic do you see?  Does it show it as the PPPoE frames, or the IP to such and such service on the web?  can you discern any difference between the IGMP and other standard traffic?
My understanding is that the IGMP stuff has to leave on the physical ethernet interface, not encapsulated in the PPPoE frames - as the IGMP stuff only travels as far as the cabinet, where it works it's magic and subscribes you to the relevant multicast stream.
DougMa
Grafter
Posts: 115
Thanks: 3
Registered: ‎09-09-2011

Re: Multicast config for alternative routers

Excellent question.
I see the IGMP request sourced with my Plusnet WAN IP address encapsulated in PPP within VLAN 101: alongside all my regular traffic. I can also see BT's management traffic in VLAN 301. 
It makes sense that this needs to be outside the PPP, but can anyone confirm if the streams run over VLAN 101?
It would be helpful to see a technical reference for Openreach's implementation.  I'll try to define a new virtual interface that sits alongside the PPP interface and find a way to define it as the IGMP proxy.
Thanks,
Doug
jimbof
Grafter
Posts: 348
Thanks: 2
Registered: ‎02-05-2013

Re: Multicast config for alternative routers

I don't know about the VLAN issue and it is something I had pondered - on my openWRT box I haven't configured any VLANs on the interfaces and it all seems to work fine (except the issue I currently have with the Sky NowTV stuff, which I believe is unrelated).  I had to do as you mention - set up a separate "interface" and make the IGMP proxy talk to that instead of the PPP interface.  I don't think my setup is quite optimal (firewall could be tightened further, don't like having to assign an IP address to the physical LAN interface), but it does seem to work.
DougMa
Grafter
Posts: 115
Thanks: 3
Registered: ‎09-09-2011

Re: Multicast config for alternative routers

Success for the Fritz!Box 7390 as a combined VDSL2 modem/router!  But it was not easy...
Firstly, I found BT's requirements for customer premise equipment to act as a reference for what I needed to configure.  The relevant section is 3.2.4 (WAN VLAN Layer):
[quote=http://www.sinet.bt.com/sinet/sins/pdf/498v5p1.pdf]Where the CP intends to use Multicast, IGMP reports destined for Openreach Multicast for GEA shall be encoded as IGMPv3 or IGMPv2 over C-VLAN ID 101. Source Specific Multicast option within IGMPv3 must not be used.
Where the CP is using PPP and intends to use Multicast for GEA, the modem shall be able to detect and process multicast frames differently to unicast. Multicast for GEA frames sent into Openreach (IGMP reports) shall not be encapsulated with PPP otherwise they will passed transparently as normal GEA traffic.
With that in-mind, I downloaded the configuration from the Fritz and edited it to include a new sub interface named IPTV.  I discovered that the interface had to be configured with an IP address for it to come-up.  Here is a unified diff showing the changes I made:
--- FRITZ.Box Fon WLAN 7390 Pre-IGMP Edit.export	2014-04-12 22:14:59.000000000 +0100
+++ FRITZ.Box Fon WLAN 7390 IGMP Edit.export 2014-04-12 21:41:01.000000000 +0100
@@ -6,6 +6,7 @@
OEM=avme
Country=044
Language=en
+NoChecks=yes
**** CFGFILE:ar7.cfg
/*
  * /var/flash/ar7.cfg
@@ -225,9 +226,9 @@
                ipbridgeing = no;
                ipbridgeing_igmp = no;
                pppoeforwarding = no;
-                connections = "internet", "voip";
+                connections = "internet", "voip", "iptv";
        }
-        mcupstream = "internet";
+        mcupstream = "iptv";
        voip_forwardrules = "udp 0.0.0.0:5060 0.0.0.0:5060",
                            "tcp 0.0.0.0:5060 0.0.0.0:5060",
                            "udp 0.0.0.0:7078+32 0.0.0.0:7078";
@@ -318,6 +319,78 @@
                dhcp_requests_with_client_id = yes;
        } {
                enabled = yes;
+                name = "iptv";
+                weight = 50;
+                dsl_encap = dslencap_ether;
+                dslinterfacename = "dsl";
+                no_masquerading = no;
+                use_fixed_masqaddr_if_no_masquerading = no;
+                no_firewall = no;
+                stackmode = stackmode_ipv4only;
+                pppoevlanauto = no;
+                pppoevlanauto_startwithvlan = no;
+                vlancfg {
+                        vlanencap = vlanencap_fixed_prio;
+                        vlanid = 101;
+                        vlanprio = 0;
+                }
+                ppptarget = "iptv";
+                fixed_masqaddr = 0.0.0.0;
+                mtu = 0;
+                etherencapcfg {
+                        use_dhcp = no;
+                        use_dhcp_if_not_encap_ether = no;
+                        ipaddr = 1.0.0.1;
+                        netmask = 255.255.255.252;
+                        gateway = 0.0.0.0;
+                        dns1 = 0.0.0.0;
+                        dns2 = 0.0.0.0;
+                }
+                is_mcupstream = yes;
+                ap2ap = ap2ap_auto;
+                ap2ap_qos = yes;
+                stay_always_online = yes;
+                disable_ondemand = no;
+                reconnect_delay_after_conn_abort = 30s;
+                only_route_when_connected = no;
+                redial_delay_after_auth_failure = 1m;
+                redial_limit = 3;
+                redial_after_limit_reached = 10m;
+                redial_after_limit_reached_variance = 5m;
+                redial_delay_after_low_error = 10s;
+                redial_delay_after_ppp_timeout = 10s;
+                redial_delay_after_ppp_error = 0w;
+                routes_only_for_local = no;
+                dproutes_only_for_local = no;
+                disable_staticroutes_on_dhcproutes = no;
+                ripv2receiver_enabled = no;
+                ripv2_update_timer = 30s;
+                ripv2authmode = ripv2_auth_none;
+                ripv2md5_keyid = 0;
+                ripv2passwd = "";
+                set_replicate_dhcpoptions_in_parameter_request_list = no;
+                unset_ignored_dhcpoptions_in_parameter_request_list = yes;
+                dsldpconfig {
+                        security = dpsec_firewall;
+                        filter_teredo = yes;
+                        filter_netbios = yes;
+                        lowinput {
+                                policy = "permit";
+                        }
+                        lowoutput {
+                                policy = "permit";
+                        }
+                        highinput {
+                                policy = "permit";
+                        }
+                        highoutput {
+                                policy = "permit";
+                        }
+                }
+                dhcp_auth_mode = auth_none;
+                dhcp_requests_with_client_id = yes;
+        } {
+                enabled = yes;
                name = "voip";
                weight = 50;
                dsl_encap = dslencap_inherit;
@@ -498,6 +571,63 @@
                passiv_on_outgoing = no;
                mode6 = mode6_off;
                mode4 = mode4_normal;
+        } {
+                type = pppcfg_target_internet;
+                name = "iptv";
+                only_crypt_auth = no;
+                local {
+                        username = "";
+                        passwd = "";
+                }
+                remoteauth = pppcfg_authtype_chap;
+                remoteauth_only_on_incoming = yes;
+                remote {
+                }
+                inactivity_timeout = 0w;
+                bUseChargeInterval = no;
+                nChargeInterval = 1m;
+                lcpecho_disconnect_mode = lcpecho_auto;
+                logicaldisconnect_with_physical = yes;
+                disconnect_timeout = 0w;
+                finaldisconnectcall = no;
+                ipnetbiosspoofing = no;
+                dnsfilter_for_active_directory = no;
+                no_outgoing_calls = no;
+                coso = pppcfg_coso_caller;
+                callback_delay = 1s;
+                icbmode = pppcfg_icbmode_none;
+                ocbmode = pppcfg_ocbmode_none;
+                mscbprefered = no;
+                multilink {
+                        extra_static_channels = 0;
+                        max_channels = 1;
+                        automatic = no;
+                        automatic_param {
+                                window = 20s;
+                                add_percent = 85;
+                                drop_percent = 70;
+                                sportlich = no;
+                        }
+                }
+                header_compression = yes;
+                data_compression = pppcfg_datacomp_auto;
+                stac_reset_with_history_number = no;
+                encryption = pppcfg_crypt_none;
+                inactivity_prevention_interval = 0w;
+                new_ipaddr_on_connect = no;
+                my_ipaddr = 0.0.0.0;
+                his_ipaddr = 0.0.0.0;
+                overwrite_dns1 = 0.0.0.0;
+                overwrite_dns2 = 0.0.0.0;
+                bVolumeRoundUp = no;
+                VolumeRoundUpBytes = 0;
+                bProviderDisconnectPrevention = no;
+                ProviderDisconnectPreventionInterval = 1d;
+                ProviderDisconnectPreventionHour = 3;
+                bProviderDisconnectPreventionHourSet = yes;
+                passiv_on_outgoing = no;
+                mode6 = mode6_off;
+                mode4 = mode4_normal;
        }
        dslglobalconfig {
                autodetect = no;

Definitely not for the faint-of-heart!  I'll send my findings to AVM and ask if they can create an ISP profile covering Openreach GEA Multicast, making this configuration automatic should the user select the right profile.
Doug
jimbof
Grafter
Posts: 348
Thanks: 2
Registered: ‎02-05-2013

Re: Multicast config for alternative routers

Cool, so you've basically done the same as I did on a different platform.  I think the VLAN ID stuff is only required on integrated VDSL modems.
How did you choose the IP address for your VDSL WAN interface?  Do you think it matters what you choose?
DougMa
Grafter
Posts: 115
Thanks: 3
Registered: ‎09-09-2011

Re: Multicast config for alternative routers

Yes, the VLAN is typically handled by the Openreach modem: it simply bridges everything received on the Ethernet interface onto VLAN101.  Those of us using integrated modems have to tag packets with the correct VLAN
In my haste I chose a poor IP address, I really should have gone with a link-local address (RFC3927: 169.254.1.0 through 169.254.254.255) to guarantee no conflict with a real IP on the Internet or over a VPN.  Since I've limited the network mask to /30 there is no practical risk: and 1.0.0.0/24 is a reserved network (1.0.0.0/8 used to be reserved, but APNIC made it available to help combat the IPv4 shortage: they held back the first /24 because of people like me using it for point-to-point links!)
Doug
jimbof
Grafter
Posts: 348
Thanks: 2
Registered: ‎02-05-2013

Re: Multicast config for alternative routers

I'm intrigued to know if the plusnet router has to employ the same "trick" or whether there is a proper way to do it...
Exile
Hooked
Posts: 7
Registered: ‎09-08-2007

Re: Multicast config for alternative routers

Configuration for the ASUS rt-n56u (Humax connected to router via Solwise 500Mbps homeplugs)
My attempt to enable multicast using Padavan's custom firmware was unsuccessful, so I flashed to the latest official ASUS firmware 3.0.0.4.374.4561 and applied the following settings:
In WAN
Enable VPN + DHCP Connection = No
In LAN->Switch Control
Unknown multicast storm control(Mbps) = 40
Multicast storm control(Mbps) = 40
(Needed to support 2 concurrent hi-def streams)
In LAN->IPTV
Select ISP Profile = None
Choose IPTV STB Port = None
Use DHCP routes = Microsoft
Enable Multicast Routing (IGMP Proxy) = Enable
UDP Proxy(Udpxy) = 0
I found that the LAN->IPTV changes could not be set in any of the browsers I tried using firmware 3.0.0.4.374.4561, so I flashed back to 3.0.0.4.374.4422 applied the changes, then flashed back to 3.0.0.4.374.4561.
When viewing IPTV channels all devices on the network using 2.4GHz wireless disconnected (5GHz was unaffected). After experimentation I found the following change fixed this.
Wireless->Professional
Frequency = 2.4GHz
Enable IGMP Snooping = Enable
Community Veteran
Posts: 6,320
Thanks: 86
Fixes: 3
Registered: ‎08-01-2008

Re: Multicast config for alternative routers

Quote from: DougMa
Success for the Fritz!Box 7390 as a combined VDSL2 modem/router!  But it was not easy...
.............
Doug

You legend Doug! (if you don't mind me saying so).
I was about to give up on the Fritz!Box but may well try to understand what you've done and apply it to mine.  I may be back with some questions if you don't mind.
Call me 'w23'
At any given moment in the universe many things happen. Coincidence is a matter of how close these events are in space, time and relationship.
Opinions expressed in forum posts are those of the poster, others may have different views.
Community Veteran
Posts: 6,320
Thanks: 86
Fixes: 3
Registered: ‎08-01-2008

Re: Multicast config for alternative routers

Well, finally got the Fritz!Box working (thanks DougMa), took a couple of attempts but finally found a mistake in my edit of the backup.
I have an old Humax YouView box as well as the PN supplied one, I can confirm that both boxes work.
Tried running a couple of speedtests while watching an HD channel just to prove that maxing out the bandwidth didn't affect the TV (see attached).
Call me 'w23'
At any given moment in the universe many things happen. Coincidence is a matter of how close these events are in space, time and relationship.
Opinions expressed in forum posts are those of the poster, others may have different views.
kianhatchman
Newbie
Posts: 6
Registered: ‎16-03-2013

Re: Multicast config for alternative routers

Just in case it is of any use to somebody else who has a Draytek Router.
I tried the test method, using VLC and opening the BT test media stream method referenced in this post (http://community.plus.net/forum/index.php/topic,124116.0.html) - although I did not bother with WireShark - It sat there with a blank black screen. Tried the IP channels (900 as a test) and got the 'Problem with channel: 6023 Error' style message.
We have a Draytek 2830 Router with the latest firmware - and I did not want to change away from this unless I absolutely had to, so went into the router control panel - there is a neatly labelled selection under 'Applications' menu, called 'IGMP' - selecting this presented a tick box to enable IGMP Multicast on whichever WAN port you choose - obviously I enabled it on the BTOpenreach Fibre modem port, and within a second or two my IP TV channels burst into life, displaying the BT test channel.
In summary, if you have a Draytek router (2830 in my case), then IGMP is disabled out of the box, but a single check box (see image) and clicking apply enables it without any additional configuration. We also have a static IP (single) allocated to our Plusnet Fibre.