cancel
Showing results for 
Search instead for 
Did you mean: 

2 X BT Sport problems

scotthatton
Dabbler
Posts: 10
Registered: ‎04-09-2015

2 X BT Sport problems

Hi Plusnet Team

Can you help me with 2 x BT Sport problems?

I recently switched over from BT Fibre Broadband to yourselves. On BT I had no issues watching BT Sport on the basic Youview box from them.

My Plusnet Fibre Broadband went live last Thursday and I also ordered the Youview+ box from you. My set is unchanged - TV box is linked to the hub via devolo Powerline adapters.

However, BT Sport is super glichy especially on HD. I didn't have this issue with BT. I've tried resetting everything. Can you spot any issues? Is my Broadband ok? Seems slower than BT but never quite sure. The line should be able to support around 35 Mbps.
When I log into my account to look at my settings I'm just getting a white page. Not sure why that is?

Second issue is with BT Sport app. I followed the registration instructions but I used my existing BT account. This seems to have confused BT. I keep getting asked to activate the account but then told it's already activated. So I'm blocked from logging in.
Looking at this forum seems there is a way to unlink the accounts, so I can start again, using a brand new BT account. Can you do this for me please?

Thanks Scott
Tags (1)
7 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 14,004
Thanks: 285
Fixes: 84
Registered: ‎27-04-2007

Re: 2 X BT Sport problems

Hi there, 

 

Could you send me a PM with your username please so I can have a look into this for you?

 

Adam 

 

If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
scotthatton
Dabbler
Posts: 10
Registered: ‎04-09-2015

Re: 2 X BT Sport problems

PM sent - thanks Adam

Plusnet Help Team
Plusnet Help Team
Posts: 14,004
Thanks: 285
Fixes: 84
Registered: ‎27-04-2007

Re: 2 X BT Sport problems

Cheers for the message. 

 

I've been running diagnostics on the line but we're not seeing any obvious problems. 

 

I take it you're able to stream other services (iPlayer etc) without any issues using the same setup?

 

With regards to the BT ID activation problem, if you delete your browser's cache of cookies and temporary internet files before following the link from the original email we sent that should allow you to set up a new one. 

 

 

If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
scotthatton
Dabbler
Posts: 10
Registered: ‎04-09-2015

Re: 2 X BT Sport problems

Hi Adam,

 

All other streaming services are ok.   But tonight I will test with an ethernet cable direct from the hub - to rule out the Powerline adaptors.

I cannot see my connection speed.  As I mentioned in my PM, all my Member Services screens are blank.  Is this normal?

2019-01-21 16_44_38-Start.gif

 

Message Edit -  BT Sport App now logged in ok.  Thanks for that.

 

Thanks
Scott

Superuser
Superuser
Posts: 3,007
Thanks: 711
Fixes: 7
Registered: ‎06-04-2007

Re: 2 X BT Sport problems

Hi Scott

 

The white screen isn't normal, but is something a number of us have seen since late last week: https://community.plus.net/t5/My-Account-Billing/White-Screen-of-death/td-p/1606564

 

Phil

scotthatton
Dabbler
Posts: 10
Registered: ‎04-09-2015

Re: 2 X BT Sport problems

Thanks Phil.  I've added my feedback on that thread.  I didn't spot that one when searching. 

Only been with Plusnet since Thursday (after a 4 year break) - not a great return so far.

scotthatton
Dabbler
Posts: 10
Registered: ‎04-09-2015

Re: 2 X BT Sport problems

Just to close the loop on the BT Sport glitch problem - I had a swap around on my PowerLine adaptors, and have upgraded the link between the hub and the TV box to 500Mpbs (from 200).   So far (fingers crossed) channels are ok!  

It was strange as it didn't impact iPlayer or ITV hub, only BT Sport...  And my old BT Broadband box was fine - but I didn't have HD with BT.

 

So if you can just sort out this ridiculous "white screen" issue on the account pages I would be a happy customer.  I cannot believe I am unable to use 90% of the pages...  Bills/calls/usage don't work...  FEEDBACK PLEASE!2019-01-21 16_44_38-Start.gif