cancel
Showing results for 
Search instead for 
Did you mean: 

some mails not displaying

Community Veteran
Posts: 1,850
Registered: 11-08-2007

some mails not displaying

i'm subscribed to a couple of firms whose emails don't display anything but the header info from/to.  they display ok in squirrel.
18 REPLIES
Superuser
Superuser
Posts: 8,950
Thanks: 449
Fixes: 38
Registered: 06-04-2007

Re: some mails not displaying

Is this because the messages are HTML only and Roundcube is set not to display HTML?
If you display the message source (right-hand icon when the message should be displayd) does this give any clues?
David
Community Veteran
Posts: 1,850
Registered: 11-08-2007

Re: some mails not displaying

it's set to display html.  what icon am i looking for for message source?  i don't see anything pertinent.
Superuser
Superuser
Posts: 8,950
Thanks: 449
Fixes: 38
Registered: 06-04-2007

Re: some mails not displaying

If I double-click a message in the message list to display it a ""Show source" icon appears above the message. This looks like a sheet of paper with the corner turned down and has a large S on it. It is positioned between the "Print" icon and "Move to" box.
David
Community Veteran
Posts: 1,850
Registered: 11-08-2007

Re: some mails not displaying

thanks.  i hadn't thought of that.  unfortunately the 'S' doesn't work.  it's greyed out.
Superuser
Superuser
Posts: 8,950
Thanks: 449
Fixes: 38
Registered: 06-04-2007

Re: some mails not displaying

No matter which message I look at, and whatever folder it is in, the Show source icon for me is never greyed out. When I click on the icon another window opens to display the source.
So it looks as though there must be something peculiar in the messages you received that Roundcube doesn't like, but SquirrelMail isn't bothered about. Is the Show source icon greyed out on all your messages or just the "blank" ones?
Perhaps resolving this requires a Plusnet staff member to take a look at them.
David
Community Veteran
Posts: 1,850
Registered: 11-08-2007

Re: some mails not displaying

no.  i can use it on other emails just as you described.
Superuser
Superuser
Posts: 8,950
Thanks: 449
Fixes: 38
Registered: 06-04-2007

Re: some mails not displaying

It's possible the problem is that the messages are malformed, which is an originator problem.
The following Roundcube Bug-Tickets describe symptoms similar to yours:
Ticket #1485411
Ticket #1485429
There is a suggestion that the problem was to be worked around in the 0.2-stable version but it's still down as an active bug so I guess it hasn't been.
David
Community Veteran
Posts: 1,850
Registered: 11-08-2007

Re: some mails not displaying

so long as alternatives remain, i shan't worry about it.  thanks for your help.
drj
Aspiring Pro
Posts: 1,091
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: some mails not displaying

I have a similar problem - some emails from eBay display in their entirety in either the preview pane or when opened - others just show a few lines. However if you hit Froward the full content is visible.
drj
Aspiring Pro
Posts: 1,091
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: some mails not displaying

To clarify my previous point, some emails from eBay headed "Your watched eBay items are ending soon" display just the eBay logo and "eBay sent this message to David" whereas other ones virtually identical - i.e. still "Your watched eBay items are ending soon" - display the full content
Since they don't even display when fully opened I may have to abandon RoundCube email entirely - and ultimately PlusNet email...
Superuser
Superuser
Posts: 8,950
Thanks: 449
Fixes: 38
Registered: 06-04-2007

Re: some mails not displaying

Do both forms of message display correctly using SquirrelMail?
David
drj
Aspiring Pro
Posts: 1,091
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: some mails not displaying

Yes
Viewing the source code once downloaded it appears that RC cannot handle a character which shows as a round dot in OE and a square in SM and has the coding "=07 ". There is nothing at all after that point on the RC screen either in preview or opened.
dick:quote
drj
Aspiring Pro
Posts: 1,091
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: some mails not displaying

Here's a screenshot of the problem I've highlighted - the text in the email is cut off half way through my name and I can't get the rest to display either in preview mode or when opened up. The only way to read the email properly is to download it to OE.
drj
Aspiring Pro
Posts: 1,091
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: some mails not displaying

Can I presume no one has a solution to this fundamental problem which makes RC unusable for some eBay emails?