cancel
Showing results for 
Search instead for 
Did you mean: 

Just moved to Plusnet

keithleason
Browser
Posts: 1
Thanks: 1
Registered: ‎07-03-2017

Just moved to Plusnet

My transfer to Plusnet broadband was this morning.

At last I have found a provider who delivers the service promised. Router arrived as promised and service activated when promised.
Speed much in proved. My previous provider were a set of muppets.

Thanks Plusnet.
3 REPLIES 3
rongtw
Seasoned Hero
Posts: 6,973
Thanks: 1,541
Fixes: 12
Registered: ‎01-12-2010

Re: Just moved to Plusnet

This is what should happen every time Thumbs_Up

Asus ROG Hero Vii Z97 , Intel i5 4690k ,ROG Asus Strix 1070,
samsung 850evo 250gig , WD black 2 TB . Asus Phoebus sound ,
16 gig Avexir ram 2400 , water cooling Corsair H100i gtx ,
Corsair 750HXI Psu , Phanteks Enthoo pro case .
NickButler
Browser
Posts: 1
Registered: ‎07-03-2017

Re: Just moved to Plusnet

I too joined PlusNet today, No router ( apparently they forgot to send me one) so I've had to change the settings on my existing router and then wait for 20 minutes on the phone whilst the broadband was actually switched on.  Best download speed so far 1.9Mbs despite being promised 4.5 to 6.5.  This has not been one of my better decisions.

Also received 11 texts so far today telling me my phone service is now available

 

It is only day 1 and so far this company does not fill me with confidence

Anoush
Aspiring Hero
Posts: 2,568
Thanks: 570
Fixes: 139
Registered: ‎22-08-2015

Re: Just moved to Plusnet

Hi there @keithleason first of all a warm welcome to the community forums Smiley

 

Thanks for posting about your positive experience, always good to hear back when things go to plan. If there's ever anything we can help with please feel free to let me know.

 

@NickButler - Sorry to hear of your poor experience. I've tested your line and I can see your router is in sync at 5.6 Mbps within your estimated speed range of between 4.5 Mbps and 6.5 Mbps. Are you connecting using a wireless or wired connection?

This is my personal Community Forum account to help out around these parts while I'm at home. If I'm posting from the 1st March 2020, this means I'm off-duty with no access to internal systems.
If this post resolved your issue, please click the 'This fixed my problem' button