cancel
Showing results for 
Search instead for 
Did you mean: 

how to set hub one tcp time_wait (port map time setting)

percepts
Dabbler
Posts: 16
Registered: 01-06-2016

how to set hub one tcp time_wait (port map time setting)

is there a way to telnet into my hub one router and manually set the port map time settting for the tcp time_wait ?

its default setting is too long for my liking and causes various email clients I have tested to to time out.

This was never a problem with my old adsl router supplied by plusnet but this new hub one vdsl router for fibre is a PITA!

Support tried to tell me it was my email client that was the problem. I know they try and be helpful but when its something outside their limited sphere of knowledge, trying to fob me off with dim wit answers blaming the email client and refusing to acknowledge it could be a router problem is pure contempt for their customers.

Moderator's note by Mike (Mav): Derogatory comment removed

 

 

27 REPLIES
bill888
Seasoned Pro
Posts: 801
Thanks: 103
Fixes: 20
Registered: 18-10-2008

Re: how to set hub one tcp time_wait (port map time setting)

No, is the simple answer to your telnet query.  Hub One is based on BT Home Hub 5 type A.

Experimental OpenWRT and LEDE open source firmware is available for the Home Hub 5A, but I don't recommend using it unless you have a spare router to fall back to using, should you brick or damage the Hub One while soldering wires to it. (And the warranty will be invalidated)

https://community.plus.net/t5/Tech-Help-Software-Hardware-etc/Running-OpenWRT-on-the-Plusnet-Hub-One...

 

 

Community Gaffer
Community Gaffer
Posts: 12,857
Thanks: 675
Fixes: 65
Registered: 04-04-2007

Re: how to set hub one tcp time_wait (port map time setting)

What email clients is it causing to time out? I had few problems when I was using a Hub One with either Thunderbird, Outlook 2013 or Windows 10 Mail?

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

percepts
Dabbler
Posts: 16
Registered: 01-06-2016

Re: how to set hub one tcp time_wait (port map time setting)

the problem is the router and not the email client. You're not going to waste my time going down that path.

percepts
Dabbler
Posts: 16
Registered: 01-06-2016

Re: how to set hub one tcp time_wait (port map time setting)

Looks like a new router or preferably an internal vdsl modem is in order then. I have my eye on one about to be released at great expense but I can't be doing with this hub one pile of junk.

percepts
Dabbler
Posts: 16
Registered: 01-06-2016

Re: how to set hub one tcp time_wait (port map time setting)

and...

 

bobpullen, can you tell us how long the hub one router has its default TCP Time_Wait set to? There are norms for these settings and you or your technical people should know this or be able to get it from BT if they don't know.

And I would point out that if you or your technical people don't know this then it makes you or your technical support people look pretty dim when they try and claim time outs are due to email clients which have been working perfectly well with the vast majority of other routers for years including the ones supplied by plusnet for adsl.

So I suggest you start looking at what the TCP time_wait settings are for your hub one routers and set them to a sensible value and not the overly long deafult and unchageable setting its currently using. Even better would be to provide a configurable option in the plusnet hub one settings panel so people could tweak it (but they shouldn't need to if its already using a sensible value and not an overly long one as is currently the case for the vast majority users)

 

Community Gaffer
Community Gaffer
Posts: 12,857
Thanks: 675
Fixes: 65
Registered: 04-04-2007

Re: how to set hub one tcp time_wait (port map time setting)

If I'm honest, I don't know what it's set to, I'd need to do some digging. TBH though, I'm not going to expend time doing so without further clarity surrounding the problem.

One of the most helpful stages of investigating issues like these tends to be an attempt to replicate them. I can't do that without an answer to my question and some further background.

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

percepts
Dabbler
Posts: 16
Registered: 01-06-2016

Re: how to set hub one tcp time_wait (port map time setting)

I tested with 3 email clients, eudora, windows live mail and thunderbird. They all exhibit the same problem. I also use a pop mailbox checker which exhibits the same problem. With my old thmopson router for adsl supplied by plusnet the problem didn't exist.

You should know I run my own mailserver on same pc as my email clients and i have about 10 mailboxes all of which are connected to and fecthed from exactly the same way as prior to installing the hub one.

So given that the only thing that changed was the router and faster line, the only thing that could cause the problem is the changed hardware.

First pop fetch to email client will often work fine but a second pop fetch a second or two after the first one results in time outs, Checking my port status utility says the port is in a time_wait state, i.e. the router has still got a hold of the connection. So problem is router has not released the connection.

I may be using the router in a heavier workload than the average home user but I once again stress that my old thomson router didn't exhibit this problem. It is only the new router which exhibits the problem.

So the only way any of your technical support can claim its not the router is to know how the damn thing works and how long its TCP time_wait settings are and possibly the maximum number of connections it allows at any one time which could also be a factor. Either way the old thomson router could handle it without a problem. The new one can't.

 

 

Community Gaffer
Community Gaffer
Posts: 12,857
Thanks: 675
Fixes: 65
Registered: 04-04-2007

Re: how to set hub one tcp time_wait (port map time setting)

What POP mailbox checker and how frequently are these clients polling?

What local/remote ports is your mail server using and is that POP collection too?

If I asked you to lower the MTU of the PC the server/clients are installed on, would you be comfortable doing that?

I have a niggling suspicion.

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

percepts
Dabbler
Posts: 16
Registered: 01-06-2016

Re: how to set hub one tcp time_wait (port map time setting)

poppeeper and it polls once everyt 10 minutes which works fine. But again if i do a manual poll a couple of seconds after previous one it timesout. i.e. exactly the same as happens in email clients but never used to happen on old router.

 

p.s. I'm not using IMAP.

Community Veteran
Posts: 4,917
Thanks: 336
Fixes: 16
Registered: 10-06-2010

Re: how to set hub one tcp time_wait (port map time setting)

I thought you must be referring to something like nf_conntrack_tcp_timeout_time_wait, but I'm not sure what you've said about the router having not released the connection makes any sense.

You'll probably see lots of closed connections in the TIME_WAIT state when things are working normally. The TIME_WAIT TCP state is nothing to do with the router.

Even if you were talking about nf_conntrack_tcp_timeout_time_wait, I'm not sure why the setting being too high would cause timeouts.

It sounds more like some sort of firewall anti-DoS feature, that might be blocking connections if you try to make them that rapidly.

Community Gaffer
Community Gaffer
Posts: 12,857
Thanks: 675
Fixes: 65
Registered: 04-04-2007

Re: how to set hub one tcp time_wait (port map time setting)

Is it a Windows machine where most of your stuff's installed?

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

percepts
Dabbler
Posts: 16
Registered: 01-06-2016

Re: how to set hub one tcp time_wait (port map time setting)

all windows 7

Community Veteran
Posts: 4,757
Thanks: 1,048
Fixes: 27
Registered: 16-10-2014

Re: how to set hub one tcp time_wait (port map time setting)

When a connection is showing a TCP_WAIT this is done to give the opposite end of the connection time to gather any packets that are being delayed or out of sync etc. As I understand it the time limit here is about 240 seconds.

Also, I suspect you may well be aware of this but you really should consider moving to IMAP.

percepts
Dabbler
Posts: 16
Registered: 01-06-2016

Re: how to set hub one tcp time_wait (port map time setting)

I don't need IMAP since its all hosted on my home pc. IMAP has precisely zero benefit for me. It might if I was accessing mail remotely but I'm not and even if I was I could fecth it via pop. But we are going off on a tangent which is of prrecisely zero use in helping solve the problem I've posted about.

 

Something in the hub one server is not being released/dropped as quick as it should be and/or it has a problem with 10 or so connections being accessed in quick sucession.