cancel
Showing results for 
Search instead for 
Did you mean: 

WiFi Speed

Highlighted
kevupnorth
Newbie
Posts: 2
Registered: a week ago

WiFi Speed

Hi

I have Plusnet broadband and normally get a good speed of between 10-20mps download when measured on a wired in PC using BT Speedcheck.

On WiFi it's a different issue. My phone (Xiaomi A1) often gets a WiFi speed of less than 1. Occasionally it's as much as 30, but nomally between 0.6 and 1.5. My WiFi PC reports slightly fast but still very slow speeds.

I tried a few things to fix it:

1. I moved the router to different places, using a LAN power adapter. In some locations it worked for a bit.

2. I tried a new router. No change.

3. I looked at the channel. It's normally on a free channel, though the router puts it there "smartly".

4. I tired different devices, all WiFi devices had issues.

5. I tired different times.of the day and with different electronic devices running. There was no consistentcy.

So, it doesn't appear to be the WiFi hardware, nor the router, not the LAN speed.

Has anyone got any ideas as it's driving me mad.
5 REPLIES 5
bill888
All Star
Posts: 957
Thanks: 147
Fixes: 26
Registered: ‎18-10-2008

Re: WiFi Speed

Which model router?

If it is a Hub One, have you tried splitting 2.4 and 5 GHz wifi ?

https://community.plus.net/t5/My-Router/2-4ghz-and-or-5ghz-best-practice/td-p/1351950

 

Have you checked for wifi congestion, likely to be bad on 2.4 GHz band in high density populated areas (eg. apartment block)?

https://play.google.com/store/apps/details?id=com.farproc.wifi.analyzer&hl=en_GB

Plusnet Help Team
Plusnet Help Team
Posts: 934
Thanks: 112
Fixes: 43
Registered: ‎26-03-2018

Re: WiFi Speed

Hi @kevupnorth,

Out of interest, was the alternative router you tried also a Plusnet provided router or did you setup a 3rd party one?

If this post resolved your issue please click the 'This fixed my problem' button
 Alex H
 Plusnet Help Team
kevupnorth
Newbie
Posts: 2
Registered: a week ago

Re: WiFi Speed

3rd party - it's a Tenda T300. Pretty rubbish, only 2.4hz and only smart (can't manually set channels).
However, as the problem is identical to the one I had with the Plusnet one, I don't think it's rubbishness is the issue.
Baldrick1
Hero
Posts: 3,309
Thanks: 1,417
Fixes: 88
Registered: ‎30-06-2016

Re: WiFi Speed

@kevupnorth 

What other wireless devices do you have running? Devices such as cordless phones are not detected by Wifi sniffer apps and can kill wifi transmissions. Try switching all wireless devices off except the router and your device and see if things improve. If they do then switch the other stuff back on one at a time until you find the offender.

If your device supports 5GHz then split the Hub One channels as suggested by @bill888  and try each band in turn.

Plusnet Help Team
Plusnet Help Team
Posts: 1,590
Thanks: 263
Fixes: 55
Registered: ‎26-03-2018

Re: WiFi Speed

Hi @kevupnorth 

 

If you can give all the steps suggest a go and let us know if there is any change? 

 

Thanks, 

MoR

If this post resolved your issue please click the 'This fixed my problem' button
 MoR
 Plusnet Help Team