cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to view Youtube videos on Ipads/Android phones after new Netgrear D7800 Nighthawk X4S setup.

FIXED
PV1541
Hooked
Posts: 5
Registered: 10-11-2017

Unable to view Youtube videos on Ipads/Android phones after new Netgrear D7800 Nighthawk X4S setup.

I've recently purchased the router highlighted above. It carried out an auto install of Plusnet settings in the the installation process. Everything appears to be working fine, except Youtube videos will no longer play using the Ipad and Android Youtube apps. There was no issue with access with my old Netgear router.

The app will open ok. It will start to play the video but then just hangs. Youtube works fine if I navigate through Chrome to the m.youtube.com site. I also have no problem accessing through the various latops in the house.

Something is stopping Youtube being accessed through the apps.

Ive tried deleting and reinstalling the app. This allows one YouTube video to be played. The second video just hangs. This happens on all three IPads.they were working fine before I installed the new router.

Any ideas?

Many thanks

Paul

 

5 REPLIES
bill888
Seasoned Pro
Posts: 801
Thanks: 103
Fixes: 20
Registered: 18-10-2008

Re: Unable to view Youtube videos on Ipads/Android phones after new Netgrear D7800 Nighthawk X4S set

Just my two pennies worth.  Check the MTU.  Try 1492 or less.

See page 93 of D7800 user manual:

http://www.downloads.netgear.com/files/GDC/D7800/D7800_UM_15Sep2015.pdf

PV1541
Hooked
Posts: 5
Registered: 10-11-2017

Re: Unable to view Youtube videos on Ipads/Android phones after new Netgrear D7800 Nighthawk X4S set

Thanks Bill888, I'll give it a try tomorrow and report back.
PV1541
Hooked
Posts: 5
Registered: 10-11-2017

Re: Unable to view Youtube videos on Ipads/Android phones after new Netgrear D7800 Nighthawk X4S set

I tried to change the settings Bill888. They are set at 1458 so I thought I'd give them a try at 1492. I enter the value 1492 and click apply. The router goes through the process of changing the settings but won't save 1492, the value always reverts to 1458.

Any ideas?

Cheers

Paul

bill888
Seasoned Pro
Posts: 801
Thanks: 103
Fixes: 20
Registered: 18-10-2008

Re: Unable to view Youtube videos on Ipads/Android phones after new Netgrear D7800 Nighthawk X4S set

Fix

 

Do you have Plusnet upto 17mb ADSL broadband ?

According to page 94 of the Netgear D7800 manual, MTU of 1458 is for PPPoA ADSL connection.  

Nevertheless, I'm surprised the Netgear won't permit you to change the MTU.

PPPoA ADSL can work happily with MTU 1500. Will the D7800 let you set this value?

Otherwise, it looks awfully like a bug or 'feature' in the D7800 firmware.

If you are connecting to Plusnet's upto 17mb ADSL broadband, the only other suggestion is to reconfigure your D7800 to use PPPoE on ADSL, not PPPoA on ADSL connection.  Then you should be able to try larger MTU of 1492.

Go to the Inter Setup page and make a note of the existing settings.  Then you need to change the multiplexing method to LLC-BASED, and select PPPoE as shown below.

0D7800pppoeADSL.jpg

  

In 'theory' MTU of 1458 shouldn't cause issues so I am surprised you are having issues.

Are you able to check the MTU value set on your previous Netgear router?

 

PV1541
Hooked
Posts: 5
Registered: 10-11-2017

Re: Unable to view Youtube videos on Ipads/Android phones after new Netgrear D7800 Nighthawk X4S set

Thanks for the time you've taken looking at this problem Bill888. The good news is the Apple and Android Youtube apps are now working.

I am indeed on Plusnet ADSL 17mb broadband. I checked the previous router and the MTU was set to 1458.

The D700 wouldn't let me change the MTU value to anything else, so I've carried out your suggestion os setting up as LLC-Based PPPoE. The MTU is set as 1492.

Everything now appears to be working.

Many thanks for your help once again!

PV1541