cancel
Showing results for 
Search instead for 
Did you mean: 

Technicolor TG582n router - can I make it assign the same IP address every time to my wifi printer?

FIXED
GetThisBusOut1
Newbie
Posts: 2
Registered: 27-06-2017

Technicolor TG582n router - can I make it assign the same IP address every time to my wifi printer?

Hello

I recently bought a (cheap) HP wireless printer which is connected to my home network and has it's own IP address and shows on the PC as connected and ready to use, but sometimes just doesn't work.  When this happens the HP "doctor" software starts up and offers to fix it for me, but then says it can't find the device.  The only way to make it work is by turning my router off and on again.

I asked about it on the HP support forum and they said it's because the IP address is different each time.  I saw a similar problem on here and somebody said "tick the 'assign the same IP address to this device' option" in the router settings.  So I tried that but couldn't find anything like that in my router, the Technicolor TG582n.  Does it not have this facility?

The HP forum tried to explain the problem and how to get around it but I don't understand it, I'm not techy at all.

Does anyone know a way round this?  I have several things connected to the router and it's a pain to keep having to turn it off and on nearly every time I want to print. 

Today it actually worked, I have no idea why it worked today but not other days.  I'm confused :0(

Any ideas pls?

PS

Would I still get this problem if I connect the printer with a cable or is it a wireless problem? tia

Moderator's note by Mike (Mav): Post released from Spam Filter

4 REPLIES
RPMozley
Aspiring Pro
Posts: 1,066
Thanks: 21
Fixes: 3
Registered: 04-11-2011

Re: Technicolor TG582n router - can I make it assign the same IP address every time to my wifi print

Fix
Hello and welcome to the community.

Ok, you should find the setting you referred to in Home Network -> Devices -> yourHPprinter in the list. This should give you a page with more info, including MAC address of the printer, top right of the page select Configure. Then in the Addressing section you'll find the tick box for what you were looking for.
Hopefully this will solve your printing problems, or lack of printing.
Plusnet Help Team
Plusnet Help Team
Posts: 4,118
Thanks: 854
Fixes: 210
Registered: 21-04-2017

Re: Technicolor TG582n router - can I make it assign the same IP address every time to my wifi print

Hi there, first of all a warm welcome to the community forums.

 

I second RPMozley's suggestion.

 

Let us know how you get on please.

 

Anoush

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
Community Veteran
Posts: 2,909
Thanks: 168
Fixes: 3
Registered: 05-04-2007

Re: Technicolor TG582n router - can I make it assign the same IP address every time to my wifi print

Sounds like what people have said, is the cause.

I had the same problem when I first got a network printer, by default it uses DHCP (allows the router to assign an internal IP to it, but it can change later on), it works initially, so you think fine no problem. The problem is the router dishes out an new IP later on when the lease expires and it stops working. I remember having to reinstall the printer driver.

This was a few years ago and things may have moved on since then, but Windows used to do that. If the internal IP changes it won't find the printer.

Now I just assign a static internal IP to the printer outside of the DHCP range to avoid it.

Presumably the change is to say to the router "Always give it this IP".

GetThisBusOut1
Newbie
Posts: 2
Registered: 27-06-2017

Re: Technicolor TG582n router - can I make it assign the same IP address every time to my wifi print

Thank you, RPMozley.  Doh, I had looked at the Home Network/Devices page but hadn't noticed the "configure" option.  I've ticked the box and will update the thread next time I use the printer.  Thanks.

 

EDIT:  Just in case someone else has the same problem.  The printer is still working the day after I changed the setting, so hopefully that's it fixed.  Thanks again :0)