cancel
Showing results for 
Search instead for 
Did you mean: 

Still having trouble with BT HH5 Connection

Spikey_Dog
Newbie
Posts: 2
Registered: ‎10-11-2020

Still having trouble with BT HH5 Connection

HI.

Please could I have some help.  I know there are several chats about this but none of them have helped solve my problem and some of the posts seem to divert off the original subject and just becomes even more confusing!

I am still trying to connect my BT HH5 (type A) instead of the complimentary Plusnet Hub one sent to us when we transferred from BT.  The reason for the swap is that since swapping over to PN and the Hub One, the wifi has been sooo slow.  In some cases a speedtest has shown 2gb while on ethernet cable to be 60+gb.  We never had any troubles with the HH5.  Any high demand devices (the xbox, and 3x smart TV's) have been hardwired to reduce the number of wifi connections needed.  Nothing else has changed.

I have read through the many posts about making sure that user name and password contain no special characters and then clicking on the 'Connect' button.   I have tried this many many times and checked and triple checked that the login details are correct but i am still unable to connect.  The login details have been saved into the HH5 as a power cycle reveal so.

I have also tried a full factory reset and started again but still nothing.  This makes my wonder if the HH5 has been locked to BT and no matter what I try its just refuses.  Would this be the case?

 

Please could I ask for some help in simple terms,  Thank you

 

4 REPLIES 4
Baldrick1
Seasoned Hero
Posts: 6,486
Thanks: 2,924
Fixes: 190
Registered: ‎30-06-2016

Re: Still having trouble with BT HH5 Connection

@Spikey_Dog Welcome to the forum.

You must remove the DSL cable from the hub whilst you input and save your Plusnet credentials. Plug it in once you get he trying to connect message. After this it will retain the settings.

Spikey_Dog
Newbie
Posts: 2
Registered: ‎10-11-2020

Re: Still having trouble with BT HH5 Connection

many thanks for your rapid reply.  I have tried this method.  The login details ARE already saved (proved by a power cycle) and I can successfully click the 'Connect' button,   It does attempt to connect but just times out and the 'connect' button returns without actually connecting.

Baldrick1
Seasoned Hero
Posts: 6,486
Thanks: 2,924
Fixes: 190
Registered: ‎30-06-2016

Re: Still having trouble with BT HH5 Connection

@Spikey_Dog 

So to double check, you have added @plusdsl.net to your username and can use the username and password to log into your Plusnet account?

dvorak
Moderator
Moderator
Posts: 25,519
Thanks: 4,748
Fixes: 1,204
Registered: ‎11-01-2008

Re: Still having trouble with BT HH5 Connection


Moderators Note


This topic has been moved from ADSL Broadband to My Router

Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'