cancel
Showing results for 
Search instead for 
Did you mean: 

Stale addresses being returned by HubOne DNS ?

paulh
Community Veteran
Posts: 1,280
Thanks: 10
Registered: ‎30-07-2007

Stale addresses being returned by HubOne DNS ?

New HubOne (well, March 2020), but for complicated reasons have only just started doing much with my network this week.

 

HubOne is in default config, so DHCP is allocating IP addresses dynamically.

 

I run several linux boxes, some on wired, some on wireless.

Use ssh between them for management.

None of them are running any DNS servers, nscd or whatever. 

They're just plain client machines.

 

None of them have been changed since I moved house (where I had an old TG585, & everything worked perfectly)

Some of the boxes are regularly off and on, so are often getting new IP addresses.

 

The problem is that the local DNS in HubOne seems to be serving stale IP addresses, including multiple IP addresses for the same named device.

 

To illustrate, I try nslookup:

 

[code]

# nslookup pc1545

Server: 192.168.1.254
Address 1: 192.168.1.254 dsldevice.lan

Name: pc1545
Address 1: 192.168.1.72 pc1545.lan
Address 2: 192.168.1.66 pc1545.lan

 

[/code]

 

In this example, .66 is the actual live address, but the local machine uses .72 as the resolution for pc1545; accordingly, ping, ssh, rsync all fail. 

 

On  the other hand, if I look it the DHCP table on the HubOne, it is displaying only .66 for pc1545.

 

While I can think of a couple of workarounds (eg, setting fixed IP addresses for each machine on the HubOne), I can't understand why the HubOne is *apparently* caching stale results. 

 

 

halp!