cancel
Showing results for 
Search instead for 
Did you mean: 

Router not arrived

Greg76
Newbie
Posts: 3
Registered: ‎21-04-2020

Router not arrived

Hi I have been active for 2 days and still not received a router, i understand at the present time things are difficult but is there any reason why it should take 6 days to arrive? Thanks
7 REPLIES 7
adcallaghan
Newbie
Posts: 3
Registered: ‎21-04-2020

Re: Router not arrived

Exactly the same boat here. My go live date was yesterday 20/4/20. But the router was dispatched on Friday 17th April!

My account is now active but I can't use the service. 

Greg76
Newbie
Posts: 3
Registered: ‎21-04-2020

Re: Router not arrived

Apparently mine was dispatched on the 16th and can’t get through on any landline
adcallaghan
Newbie
Posts: 3
Registered: ‎21-04-2020

Re: Router not arrived

Yeah I tried customer services but they're closed I assume. What a great start. However, I guess it's just the unprecedented times we're in. I'd question how they anticipated sending it on 17th for an account that starts on 20th was ever going to work to be fair! 

MisterW
Superuser
Superuser
Posts: 9,291
Thanks: 2,302
Fixes: 173
Registered: ‎30-07-2007

Re: Router not arrived

Like everything these days its 'Just in time'. The routers are sent out first class post and usually arrive next day. However, in the current circumstances the Royal Mail arent achieving next day. I suspect the automated dispatch system isnt aware, and probably cant easily be made so, of the delays.

Greg76
Newbie
Posts: 3
Registered: ‎21-04-2020

Re: Router not arrived

I totally agree more time should have been given for router to arrive and not be paying for a device you can’t use
bobpullen
Community Gaffer
Community Gaffer
Posts: 14,832
Thanks: 2,423
Fixes: 163
Registered: ‎04-04-2007

Re: Router not arrived


@Greg76 wrote:
Apparently mine was dispatched on the 16th and can’t get through on any landline


The format of your address looks weird which I've a supsicion might explain why you didn't receive it. I'll drop you a message privately. The router was loaded onto a Royal Mail van on the 15th April, so should have arrived with you on the 16th/17th.

@adcallaghan wrote:

Exactly the same boat here. My go live date was yesterday 20/4/20. But the router was dispatched on Friday 17th April!

My account is now active but I can't use the service. 


It was actually dispatched on the 16th (the automated emails you receive are a bit misleading). It should have arrived on the 17th/18th. Any way you can check with the local depot to see if they have anything?

@adcallaghan wrote:

Yeah I tried customer services but they're closed I assume. What a great start. However, I guess it's just the unprecedented times we're in. I'd question how they anticipated sending it on 17th for an account that starts on 20th was ever going to work to be fair! 


Royal Mail First Class. As above, the router was shipped on the 16th.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

adcallaghan
Newbie
Posts: 3
Registered: ‎21-04-2020

Re: Router not arrived

Thanks For that, I’ll investigate how to contact my local Depot, fingers crossed!