cancel
Showing results for 
Search instead for 
Did you mean: 

Router appears to have died - red light no wifi

FIXED
albanyjan
Newbie
Posts: 3
Thanks: 1
Registered: ‎15-12-2018

Router appears to have died - red light no wifi

Router started flaking out earlier in the evening with pages not loading, youtube not working, so I turned the router off and on again and now I just get a red light out of it. The wifi signal doesn't pop up on any devices and I've tried connecting to it directly with a cable and logging into the 192.168.1.254 page and no such luck there. Held the reset button down for 20 secs a couple of times, nothing. Even pressed the reset button on the fibre modem box but well, i didn't expect that to magic it back into life but you never know.

 

 

Router is one of the Sagemcom 2704N models.

 

Any hot tips for getting it working again or do I have to request a new router somewhere?

4 REPLIES 4
Baldrick1
Seasoned Hero
Posts: 6,006
Thanks: 2,656
Fixes: 177
Registered: ‎30-06-2016

Re: Router appears to have died - red light no wifi

Welcome to the forum.

Why not spend £20-30 on EBay for a BT Smarthub 6. These have far superior WiFi performance. Setting up instructions will be found here. https://community.plus.net/t5/My-Router/Using-the-BT-Smarthub-6-on-a-Plusnet-Account/m-p/1587673#M85...

albanyjan
Newbie
Posts: 3
Thanks: 1
Registered: ‎15-12-2018

Re: Router appears to have died - red light no wifi

Thanks for the reply I shall have to take a look at that. I've managed to get myself back online, had a root around in the loft and found a Netgear cable router I used on Telewest over a decade ago, wasn't expecting anything but it set itself up all automatically and after putting our plusnet username and password we are back.

 

I noticed on Facebook marketplace there are people literally giving away their old plusnet routers for free so I can grab a backup easily enough, this is just a tiny bungalow so it's not like wifi reach is important or anything.

Thanks again tho! 

Gandalf
Plusnet Help Team
Plusnet Help Team
Posts: 18,266
Thanks: 5,929
Fixes: 990
Registered: ‎21-04-2017

Re: Router appears to have died - red light no wifi

Fix

Hi there.

I'm sorry to hear that your router has packed in, and I'm glad that you've found an old router to get back up and running.

Due to the age of your router we can't RMA it, but if you'd like to discuss a getting a replacement from us, I'd recommend giving our customer options team a call on 0800 013 2632.

Alternatively feel free to continue to use your Netgear or buy another 3rd party router.

Let us know if you need any assistance at all.

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
albanyjan
Newbie
Posts: 3
Thanks: 1
Registered: ‎15-12-2018

Re: Router appears to have died - red light no wifi

It's cool I've nabbed one of the same routers as the one that died for cheaps on ebay, sealed boxed one too. This old router is a bit on the slow side, but it'll still work as a backup until i sort myself out long term again.

Thanks all!