cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with broadcom network adapter

andrewgreenwood
Hooked
Posts: 7
Registered: ‎16-10-2019

Problem with broadcom network adapter

When I connect via WiFi to my PC the first 10 seconds or so work then speed drops straight to 5.5mbps and no web pages will load at all.
All devices in the home now connect fully to the WiFi yet the PC has this problem.
It states that there is a connection with internet access but as said above no webpages will load up after the initial 10 seconds.

When I connect an ethernet cable up, everything runs fine and fast so this is a wireless issue.

Could there be a problem with the network adapter in the PC? I'm unsure though as it finds and connects to the router with 4bar signal.
5 REPLIES 5
Baldrick1
Seasoned Hero
Posts: 6,029
Thanks: 2,666
Fixes: 179
Registered: ‎30-06-2016

Re: Problem with broadcom network adapter

@andrewgreenwood 

Try separating the 2.4 and 5 GHz bands on your router. See https://community.plus.net/t5/My-Router/2-4ghz-and-or-5ghz-best-practice/m-p/1351966#M840

Try each in turn and use the best.

dvorak
Moderator
Moderator
Posts: 24,808
Thanks: 4,489
Fixes: 1,139
Registered: ‎11-01-2008

Re: Problem with broadcom network adapter


Moderators Note


This topic has been moved from Fibre to My Router

Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'
andrewgreenwood
Hooked
Posts: 7
Registered: ‎16-10-2019

Re: Problem with broadcom network adapter

Hi @Baldrick1, I have already tried this with no luck. Even reset the router and tried this step again with the same result.
Baldrick1
Seasoned Hero
Posts: 6,029
Thanks: 2,666
Fixes: 179
Registered: ‎30-06-2016

Re: Problem with broadcom network adapter

You could try updating the drivers on your PC. I use the free version of Driver Booster. You will be nagged to upgrade to the paid for version so I tend to remove it after use.

andrewgreenwood
Hooked
Posts: 7
Registered: ‎16-10-2019

Re: Problem with broadcom network adapter

@Baldrick1 drivers are fully upto date, may just have to try my luck with a network home plug.