cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with TG582n Router

MSanderson
Newbie
Posts: 1
Registered: 02-05-2016

Problem with TG582n Router

I have a TG582 router connected to fibre which has been working well for several years. We have converted our top floor and wanted to get broadband up there for a TV. I diligently went off and bought some BT broadband extenders and used that to get the broadband and wifi working on the top floor. I was feeling very proud of myself...

... for about a day. Since then every evening we basically lose broadband sporadically through the house. It is strange because it is coming into the house fine, the PC on which I am writing this which is connected via an Ethernet cable to the router which is connected direct to the main junction box is always connected to the internet. However the TVs, IPads etc. can see the wifi but the wifi appears to have no broadband signal. This is also true of the TV on the top floor which I have connected directly to the broadband extender using an Ethernet cable (i.e. not via Ethernet cable). I have now disconnected the extenders in case they are the problem but the issue persists (my daughter seems to be able to use her PC, the TV says it can see the internet).

Any suggestions?

1 REPLY
Plusnet Staff
Plusnet Staff
Posts: 2,123
Thanks: 361
Fixes: 114
Registered: 22-08-2015

Re: Problem with TG582n Router

Hey there. Welcome to the forums. Have you tried changing the wireless channels in the router settings in order to avoid any potential interference from other available networks (if any)?

Also this guide could come in handy: http://www.plus.net/help/broadband/getting-the-best-wifi-signal/

Hope this helps

I've joined the Plusnet Help Team as of May 2017. As such, I have a new forum account. Please direct any queries to @Gandalf. Thanks

 Anoush Mortazavi
 Plusnet Support