cancel
Showing results for 
Search instead for 
Did you mean: 

Port Forwarding works with WiFi not Ethernet

FIXED
mxvnn
Newbie
Posts: 3
Thanks: 1
Fixes: 1
Registered: ‎21-08-2023

Port Forwarding works with WiFi not Ethernet

Hi, port forwarding (80 and 443) works fine with WiFi, but when connecting the PC directly to the router with Ethernet cable, the ports (80 and 443) are blocked. F2704N router.

Would prefer ethernet wired connection because it is much faster!

Any help would be appreciated.

 

 

6 REPLIES 6
Dan_the_Van
Aspiring Hero
Posts: 2,758
Thanks: 1,320
Fixes: 83
Registered: ‎25-06-2007

Re: Port Forwarding works with WiFi not Ethernet

Hi @mxvnn welcome to the forum.

When you are setting up the port forward rule are you using the devices hostname?

If you are then I would suggest making sure the wired IP address is static and you use that (IP Address) rather than the hostname

HTH

Mav
Moderator
Moderator
Posts: 22,428
Thanks: 4,755
Fixes: 516
Registered: ‎06-04-2007

Re: Port Forwarding works with WiFi not Ethernet

Moderator's note(s):

Thread moved from Broadband to My Router.

Forum Moderator and Customer
Courage is resistance to fear, mastery of fear, not absence of fear - Mark Twain
He who feared he would not succeed sat still

mxvnn
Newbie
Posts: 3
Thanks: 1
Fixes: 1
Registered: ‎21-08-2023

Re: Port Forwarding works with WiFi not Ethernet

Hi @Dan_the_Van, in the Port Forwarding page of the router, you do not get the option to use an IP address, there is a read-only dropdown box "Assigned to" that contains the PC's name. There is no way to edit the name.

Just to add, that I have added both TCP and UDP protocols in various combinations to no avail.

I have also turned the PC's firewall off completely and tried to connect, but the ports are still blocked on ethernet.

Used 'https://portchecker.co/' to test as well.

Kinda stuck!

 

Dan_the_Van
Aspiring Hero
Posts: 2,758
Thanks: 1,320
Fixes: 83
Registered: ‎25-06-2007

Re: Port Forwarding works with WiFi not Ethernet

@mxvnn 

Are you seeing the PC twice in the dropdown box, are you also turning off the PC WiFi before using wired?

Edit: The Home >My Home Network tab should list know devices

Testing open ports with a port checker requires the target device listening on the port you are connecting to, port checker do not usually test UDP ports.

Does netstat show port 80 and 443 listening when you have wireless off?

I do have images of this Hub but not using this Hub before I can only give generic advice.

 

 

 

 

mxvnn
Newbie
Posts: 3
Thanks: 1
Fixes: 1
Registered: ‎21-08-2023

Re: Port Forwarding works with WiFi not Ethernet

Fix

!!! Applause from the audience !!!

!!! Standing ovation !!!

If anyone else has ever or will ever encounter this problem, the solution is (drum roll please!),

The MAC address of WiFi and Ethernet are different, so you need to remove and re-add the port forwarding rules per the connection type you use.

!!! I take my bow and exit stage left, thank you my dear audience !!!

 

 

 

Dan_the_Van
Aspiring Hero
Posts: 2,758
Thanks: 1,320
Fixes: 83
Registered: ‎25-06-2007

Re: Port Forwarding works with WiFi not Ethernet

@mxvnn 

Pleased it's working

The MAC address of WiFi and Ethernet are different

That was the reasoning behind my question "Are you seeing the PC twice in the dropdown box"

As each interface would have it's own unique IP Address, you can have two rules, one for the Wireless and another Wired connection, so which interface is live at the time the forward rule would work using the IP or  MAC Address