Showing results for 
Search instead for 
Did you mean: 

Poor WiFi

Posts: 2
Registered: ‎19-11-2018

Poor WiFi

Hi all , anyone have any tips to improve WiFi strength ? I'm getting a good speed (60+) but as soon as 2 or more devices are connected it slows down to barely useable speeds , been like it for months . Tried every Chanel (1-13) and still no better , tried call centre and live chat but got bored of waiting 😶 thanks in advance (6 months into 18 month contract 😮)

Posts: 11,788
Thanks: 5,243
Fixes: 420
Registered: ‎30-06-2016

Re: Poor WiFi

The wireless performance of the Plusnet Hub is bad. Spend £20-30 on Ebay for a Smarthub 6 and get far superior  wireless performance.  Setting up instructions will be found here:

Moderator and Customer
If this helped - select the Thumb
If it fixed it,  help others - select 'This Fixed My Problem'

Aspiring Champion
Posts: 2,339
Thanks: 300
Fixes: 29
Registered: ‎02-08-2007

Re: Poor WiFi

If using the PN Hub One router (useful if your post included this key data), are you not using
5ghz band, as that's far less populated.?
Posts: 22,425
Thanks: 4,754
Fixes: 516
Registered: ‎06-04-2007

Re: Poor WiFi

Moderator's note:

Thread moved from Broadband to My Router.

Forum Moderator and Customer
Courage is resistance to fear, mastery of fear, not absence of fear - Mark Twain
He who feared he would not succeed sat still

All Star
Posts: 626
Thanks: 111
Fixes: 31
Registered: ‎06-08-2018

Re: Poor WiFi

Hi @Mick1864 and welcome to the forums!

As you have already changed the wireless channel for 2.4GHz, please try splitting the 2.4GHz / 5GHz frequencies. You can do this by following the guide below:

1) To connect to your Hub One, you will need to open a browser and go to

2) You should come to a page with information about your connection, click 'Advanced Settings' at the top and it will ask you to sign in with a Password. This is located on the back of your router under 'Admin Password'

3) Select the option for 'Wireless' followed by '5 GHz Wireless'. What we want to do to begin with is turn 'Sync with 2.4 GHz Wireless' to 'Off' and update the SSID to be different. The easiest way would be to add '-5G' to the end so it is identified as its own connection.

If the issue persists and you have a windows desktop or laptop, please press the windows key + R then type cmd and click OK.

In the command console type netsh wlan show all and hit enter, one section will display Show Networks Mode =BSSID which provides you with the channels in use by other routers in your area.

You can then select a channel in the router settings that is not as used or has less usage than other routers in your area. Once complete, please monitor the issue for reoccurring.

An alternative to using the command console is to download a free wifi analyzer on an Android or Apple device.

Let us know how you get on.

Thank you.

If this post resolved your issue please click the 'This fixed my problem' button
 Lewis G
 Infrastructure Operations Professional
Posts: 2
Registered: ‎19-11-2018

Re: Poor WiFi

Hi thanks for replying, tried the steps you suggested, changed to 5ghz , changed to off sync , updated said, didn't make any difference to be honest , used an alalyzer app that shows channels to use , soon as I select one that's on 5 stars it drops down to one star , I can sit at the side of the router but still barely usable if at all , thanks in advance 


Plusnet Help Team
Plusnet Help Team
Posts: 2,577
Thanks: 508
Fixes: 131
Registered: ‎07-12-2017

Re: Poor WiFi

Hi @Mick1864, when you un-synced the 2.4 & 5, have you tried connecting devices to the 5GHz as well (the range on this isn't as good so would be worth trying something you have closer to the router).


Also, if you haven't already, once the 2.4 & 5 are separated have you tried just solely using the 2.4GHz with all devices?

If this post resolved your issue please click the 'This fixed my problem' button
 Lauren Barry
 Plusnet Help Team