cancel
Showing results for 
Search instead for 
Did you mean: 

Plusnet Hub one router issue

ms8v
Hooked
Posts: 5
Thanks: 2
Registered: ‎10-08-2018

Plusnet Hub one router issue

Hi

Having just joined Plusnet and received the Hub one router all is working well apart from the USB flash drive.

I have 2 Win 7 machines - these see it and can use it

I also have a Win 10 machine which see's the router but not the flash drive.

Digging through the forums it appears to be an issue with SMB1 as when I reinstate this on the Win 10 machine it see's the flash drive and my file sharing etc reappears.

However, so many people now advise against using SMB1 that I worry about security.

Also if I just had the Win 10 machine then it would not see it 'out of the box'

Have done a firmware check but still showing version 4.7.51.83.8.259

Anyone got any ideas?

Thanks

8 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 540
Thanks: 132
Fixes: 27
Registered: ‎26-03-2018

Re: Plusnet Hub one router issue

Hi @ms8v 

 

Looks like there has been an accept fix to a problem very akin to yours here

 

Give it a read through and see if it helps. 

 

Thanks, 

 

 

If this post resolved your issue please click the 'This fixed my problem' button
 Alisdair C
 Plusnet Help Team
ms8v
Hooked
Posts: 5
Thanks: 2
Registered: ‎10-08-2018

Re: Plusnet Hub one router issue

Hi

Have tried this but no luck unfortunately

The only way that I can get the Win 10 machine to recognise it is still to reinstate SMB1.

Even then it will only recognise it through the network path and not the i.p. address.

Have tried creating a windows credential using the network path rather than i.p. address but no good

Any other ideas?

Regards

ms8v
Hooked
Posts: 5
Thanks: 2
Registered: ‎10-08-2018

Re: Plusnet Hub one router issue

Just to carry on from here, have attached a screendump of the type of error messages that I am getting.

There is no way that it will look at the usb drive without SMB1 client enabled even having tried the suggested fix by Microsoft.

Microsoft seem to be implying that this problem is only relevant to equipment that requires a firmware update or redesign.

Surely the Hub one router does not rely on SMB1 alone - otherwise the implication is that anyone with the latest update to Win 10 cannot use this feature?

Regards

Dunc2
Newbie
Posts: 2
Registered: ‎12-08-2018

Re: Plusnet Hub one router issue

Any Plusnet view on this? I have exactly the same problem. A brand new Plusnet Hub One with a USB socket that will only work with SMB1 enabled, thus ignoring the Windows 10 warning message: ‘You can’t connect .. not secure.. requires SMB1 protocol which is unsafe....expose your system to attack’

Community Gaffer
Community Gaffer
Posts: 13,550
Thanks: 1,243
Fixes: 102
Registered: ‎04-04-2007

Re: Plusnet Hub one router issue

I'm afraid the storage share is reliant on SMB1, and as you've discovered, a recent Windows 10 update has intentionally disabled this capability to help mitigate against recent malware/ransomware attacks.

There are no current plans to address this at the router level for the Hub One, however the situation will of course be considered for any future device.

There are ways to re-enable SMB1, but before anybody does this, I would suggest you read up on it and ensure you understand the implications.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Dunc2
Newbie
Posts: 2
Registered: ‎12-08-2018

Re: Plusnet Hub one router issue

Thanks for your fast reply Bob. Do you think it would save Plusnet's new customers an hour or so of trouble if they pointed out in their user information that the Hub One's USB socket will only work if you enable the ancient security-compromised SMB1 protocol?

Highlighted
Community Gaffer
Community Gaffer
Posts: 13,550
Thanks: 1,243
Fixes: 102
Registered: ‎04-04-2007

Re: Plusnet Hub one router issue

The situation is a relatively new development, however it's something we can consider. I think a better place for it would be online somewhere though.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

ms8v
Hooked
Posts: 5
Thanks: 2
Registered: ‎10-08-2018

Re: Plusnet Hub one router issue

There is a nice summary of it here:

https://www.theregister.co.uk/2018/06/08/windows_10_smb1/

However, as a new (to Plusnet) non technical customer I would have appreciated a notice somewhere that saved me a few hours over the weekend..

There must be loads of non technical customers with relatively up to date Win 10 machines that would just expect it to work