cancel
Showing results for 
Search instead for 
Did you mean: 

PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

Stuart_b
Hooked
Posts: 8
Registered: 06-04-2017

PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

I've had Plusnet and a Hub One broadband setup since September and until now had no issues. But in the last week, the following issue has been occurring, and I'm going round the bend trying to figure it out so I thought I'd see if anyone has had anything similar and found a solution.

 We have various laptops, mobiles, tablets, and one desktop PC in the household, and all of them can connect to the internet absolutely fine via the Plusnet router's wifi - Except for the desktop PC, which up until this week connected fine, but no longer.

The issue has the following symptoms:

* The PC (Windows 10, 64bit, with a PCI Wifi card) can see the Wifi signal from the plusnet router (2.4gh SSID)

* The PC can connect to the Wifi network (2.4gh SSID), though it takes 10-30 seconds longer than normal

* Once it has connected, it can only get a maximum connection speed of ~100kps (our connection is 14mbps, and other devices can and do get this)

* This limited connectivity lasts for 1-10 minutes, and then all access to the internet ceases on the PC. It says it is still connected to the Wifi network, but that there is no internet access on the network. Again, other devices are still working fine. When trying to access webpages I either get a "No internet connection" type of error, or, occasionally, a "Default gateway not available" error message.

* When I then try and access the router portal at 192.168.1.254 I get a message saying that the request timed out and that the IP address is not available. Bearing in mind that I am still connected to the Wifi, I don't understand how I cannot access the router - but then, I don't understand this probelm at all anyway! When I log into the router on another device (which works fine) I can see the desktop PC showing as a connected device. I also check the default gateway settings while I'm in there and see nothing amiss.

*After 10-30 minutes the desktop PC get kicked off the Wifi network, and I have to reconnect manually. WHen I do so, there is still no internet connectivity (not even the 100kbps) and eventually it just gets kciked off again after a while.

Give that this setup has been working fine up till now, I'm scratching my head to try and figure it out. So far as I can see, the Wifi network is up, it's connected to the internet, and is provideing access to devices, but my desktop PC is somehow prevented from accessing it.

I do not know if this is an issue on the PC, or the router, or both!

Anyone able to offer any advice?

18 REPLIES
Gel
Pro
Posts: 1,386
Thanks: 133
Fixes: 10
Registered: 02-08-2007

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

Try altering desktop's DNS settings to Google's
ie
8.8.8.8
8.8.4.4

Surely desktop is connected via LAN not wirelessly?
Stuart_b
Hooked
Posts: 8
Registered: 06-04-2017

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

Hi Gel

Thanks for the advice. Sadly it hasn't worked I'm afraid. There is no change in the symptoms. (I've tried a restart too, just in case).

Yes, ideally I'd have it fully wired up with an ethernet cable, but for logistical/practical reasons that sadly isn't possible in curren circumstances, so Wifi is my option Sad

On the plus side, despite distance to router, the PC reports excellent signal strength (I'll say that much for the Hub One router!).

Is there anything else I can try do you know?

Gel
Pro
Posts: 1,386
Thanks: 133
Fixes: 10
Registered: 02-08-2007

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

Try giving the 2 wireless bands differing names, and try restricting pc to 2.4 band only;
does that help?
If not restrict to 5ghz and repeat.

Another route would be to consider plug in routers as made by TP/Linksys.

Stuart_b
Hooked
Posts: 8
Registered: 06-04-2017

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

Thanks for the tip - Can you advise how I restrict it to one band or other? Not done that before.

 

Is it as simple as connecting to one SSID vs another SSID once renamed? Or is it something I need to do on the router portal?

(Yes, am considering power-plug ethernet solution as backup, but at £30-40 I'd rather try and fix it if I can! Smiley )

Gel
Pro
Posts: 1,386
Thanks: 133
Fixes: 10
Registered: 02-08-2007

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

Stuart_b
Hooked
Posts: 8
Registered: 06-04-2017

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

Hi Gel

Thanks again for trying to help me!

Sadly there is still no joy. I have split up the SSIDs as instructed, and restricted the PC to firstly 2.4Ghz. There was no change in the symptoms.

I then tried to switch to the 5GHz band but it seems that is outside the abilities of my PCI Wifi card - it only seems to be able to see the 2.4Ghz network. Which suggests unfortunately it has been restricted all along.

Apologies, I was unaware of this limitation or I'd have mentioned it and saved you the trouble of suggesting it.

Is there anything else I can try do you think?

Thanks!

Gel
Pro
Posts: 1,386
Thanks: 133
Fixes: 10
Registered: 02-08-2007

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

bill888
Seasoned Pro
Posts: 801
Thanks: 103
Fixes: 20
Registered: 18-10-2008

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

The wifi card may have gone bad.

Do you by any chance have any other old wifi router handy?  It doesn't need to be connected to your broadband connection.

Use it to test whether your desktop PC can connect to it and access that spare router's admin page when placed in same room as your Hub One.

 

 

markhawkin
Aspiring Pro
Posts: 195
Thanks: 25
Fixes: 4
Registered: 17-07-2016

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

@Stuart_b

I had a desktop machine with an ethernet cable to a router and that refused to connect to the internet for some reason. I tried every sort of reset on the card but a Windows system restore to a date when it worked sorted it and subsequent Windows updates don't seem to have broken it again.

I suspect a poor Windows update. In general networking and Windows 10 seems less reliable than older versions. I have a laptop which took a while to get the wireless stable on with Windows 10.
I am the satisfied customer....
Stuart_b
Hooked
Posts: 8
Registered: 06-04-2017

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

Thanks Gel, I hadn't realised you could get a cheap USB Dongle - good tip if I can't recover the PCI card! Thanks

Stuart_b
Hooked
Posts: 8
Registered: 06-04-2017

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

Hi Bill888, thanks very much for the advice. As it happens I do indeed have the previous router available, and have run the test as  suggested.
 
I was able to access the router portal without issue or delay on that old router (although it did take a minute or so to connect to the wifi signal, once on it loaded the router portal fine).
So I guess perhaps the PCI Wifi card is not the issue? What do you make of it?
 
Stuart_b
Hooked
Posts: 8
Registered: 06-04-2017

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

Interestingly, @bill888, after I'd connected to a different network, and then back to the original, I was able to get some limited connectivity back. 

It maintained a reasonably consistent 100kps, frequently reaching 400kbps, and once reaching 2.5mbps!!

This is progress indeed, but not yet back to normal.

@markhawkin I've tried the system restore option, but I can't get it to complete - gives me a 0x80070091 ("Appxstaging") error saying it did not complete successfully - with various restore points. Sad Presumably an unrelated, but unhelpful issue...

bill888
Seasoned Pro
Posts: 801
Thanks: 103
Fixes: 20
Registered: 18-10-2008

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

Was it any quicker to connect to old router when you put the router next to the desktop PC?

 

Also have you tried manually setting the wifi channel number to 1, 6 or 11 on the routers?

 

The other thing I've noticed is the Wireless type is set to 'upto 300mbps'.  Change it to the lower setting such as 'upto 144mbps'.

Community Veteran
Posts: 2,909
Thanks: 168
Fixes: 3
Registered: 05-04-2007

Re: PC unable to connect to internet over Hub One router Wifi, but other devices unaffected

It might be a pain, but I would move the PC temporarily and plug it in into the router through a cable and see if it works properly. If it does and given your other devices work fine, then it would point to the problem being the card.

Obviously you need to know that first before buying another and finding it still doesn't fix the problem.