cancel
Showing results for 
Search instead for 
Did you mean: 

New Hub Router very poor Wifi Connection

mezzor
Dabbler
Posts: 12
Thanks: 1
Registered: 11-07-2016

New Hub Router very poor Wifi Connection

I seem to be having none stop issues with PN at the moment but now my connection seems to have stabilised I am now experiencing very poor wifi connection from the router.

I live in a 3 story mid terrace and the router is in a living room on the second floor - When on that floor and ground floor the connection is OK - few blips here and there but no where near as bad as on the top floor where the bedrooms are.

My Laptop will lose connection completely every 5 minutes - when I say lose connection it still shows I'm connected with 3 bars but there is no internet connection whatsoever, it's the same with 3 apple devices also so I'm sure it's not a driver issue on my laptop.

The speed is not an issue, as when the connection comes back (I have to disconnect and then reconnect to the router) the speeds are 65mb instantly.

Any idea how to improve this?

 

 

 

 

 

 

 

 

 

 

7 REPLIES
Community Veteran
Posts: 1,145
Thanks: 139
Fixes: 26
Registered: 13-08-2015

Re: New Hub Router very poor Wifi Connection

Install 'inSSIDer' on your laptop and check to see which WiFi channels are clearest, and swap your router channels to those, rather than leave them on Auto. Also if its the Hub One, then separate the 2.4 and 5Ghz channels, and add a 5 to the SSID of the 5Ghz channels so you know which you are connecting to.

Plusnet Staff
Plusnet Staff
Posts: 17,640
Thanks: 534
Fixes: 159
Registered: 05-04-2007

Re: New Hub Router very poor Wifi Connection

Splitting the 2.4Ghz and 5Ghz channels is a good suggestion, I've seen Apple devices struggle when these are both the same.

If this post resolved your issue please click the 'This fixed my problem' button
 Chris Parr
 Plusnet Staff
mezzor
Dabbler
Posts: 12
Thanks: 1
Registered: 11-07-2016

Re: New Hub Router very poor Wifi Connection


Mustrum wrote:

Install 'inSSIDer' on your laptop and check to see which WiFi channels are clearest, and swap your router channels to those, rather than leave them on Auto. Also if its the Hub One, then separate the 2.4 and 5Ghz channels, and add a 5 to the SSID of the 5Ghz channels so you know which you are connecting to.


Sorry, I'm a bit simple when it comes to routers, I know I must login to access this part but how do I separate them? Is there a guide somewhere?

Community Veteran
Posts: 1,145
Thanks: 139
Fixes: 26
Registered: 13-08-2015

Re: New Hub Router very poor Wifi Connection

Go to advanced settings/Wireless/5Ghz and where it says Sync with 2.4Ghz select No.

On the same page add 5 to the SSID.

mezzor
Dabbler
Posts: 12
Thanks: 1
Registered: 11-07-2016

Re: New Hub Router very poor Wifi Connection


Mustrum wrote:

Go to advanced settings/Wireless/5Ghz and where it says Sync with 2.4Ghz select No.

On the same page add 5 to the SSID.


OK so done that, which one do I use? At the moment my iPhone can see the 5Ghz but my laptop cannot?

Kevin
Rising Star
Posts: 148
Thanks: 11
Registered: 12-10-2007

Re: New Hub Router very poor Wifi Connection

Either. My Ipad works on 2.4 or 5 quite happily.

Kevin.
stoswald
Grafter
Posts: 249
Thanks: 6
Registered: 14-03-2014

Re: New Hub Router very poor Wifi Connection

If you have a phone download wifi analyzer from the Play Store.  Run that and then see what happens.

My guess is that your router is on the same channel as a wifi signal from next door.  My wifi is often drowned out by a Talk Talk router next door that  causes problems you are experencing (It also seems to follow my router around the channels - fine for a month then I need to change channels again!) I got fed up with my son moaning, so I reverted to using home-plugs for his laptop - the complaints have stopped now!  You can also change the wifi channel if you can't use home-plugs because of circuit constraints or not wanting a loose cable to trip up on!