cancel
Showing results for 
Search instead for 
Did you mean: 

MQTT connection for IoT device not working

chrisking
Dabbler
Posts: 15
Thanks: 12
Registered: ‎04-09-2018

Re: MQTT connection for IoT device not working

@bobpullen, the device is now setup to use 212.159.6.9 for DNS

@chrisking, you can move it back to the router

 

Aaaand.... it's green.

Community Gaffer
Community Gaffer
Posts: 13,939
Thanks: 1,467
Fixes: 119
Registered: ‎04-04-2007

Re: MQTT connection for IoT device not working

Thanks guys. Seems we can squarely point the finger at the DNS proxying then.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

chrisking
Dabbler
Posts: 15
Thanks: 12
Registered: ‎04-09-2018

Re: MQTT connection for IoT device not working

It will be interesting to know how the vendor responds.

Superuser
Superuser
Posts: 7,604
Thanks: 1,396
Fixes: 89
Registered: ‎30-07-2007

Re: MQTT connection for IoT device not working

I would imagine that almost all routers use a version of dnsmasq to provide the DNS cache/forwarding.

According to the faq here http://www.thekelleys.org.uk/dnsmasq/docs/FAQ

Q: Why doesn't dnsmasq support DNS queries over TCP? Don't the RFC's specify
that?
A: Update: from version 2.10, it does. There are a few limitations:
data obtained via TCP is not cached, and source-address

or query-port specifications are ignored for TCP.

I can't find when v 2.10 was released but it's up to about 2.78 now

chrisking
Dabbler
Posts: 15
Thanks: 12
Registered: ‎04-09-2018

Re: MQTT connection for IoT device not working

Good find!

 

Looks like it dates from 2004, so if the routers are using that, they need to update.

 

Edit: thanks autocorrect 

chrisking
Dabbler
Posts: 15
Thanks: 12
Registered: ‎04-09-2018

Re: MQTT connection for IoT device not working

Pleased to say that Monitor-IO have now pushed an update that fixes the problem.

 

Good job, everyone.

 

Chris

Community Gaffer
Community Gaffer
Posts: 13,939
Thanks: 1,467
Fixes: 119
Registered: ‎04-04-2007

Re: MQTT connection for IoT device not working

@monitor-io, care to share the specifics of your fix? Was it to hard code the DNS resolvers, and thus bypass the router proxy? Or have you approached things another way?

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

monitor-io
Dabbler
Posts: 15
Thanks: 12
Registered: ‎16-07-2018

Re: MQTT connection for IoT device not working

Well, because our device is looking to validate the customer's connectivity we didn't want to always bypass whatever DNS they normally receive via DHCP from their router. So for us, the best option was to specify a set of backup public DNS servers via a "append domain-name-servers x.x.x.x, y.y.y.y;" in our dhclient.conf file. We used an "append" instead of a "prepend" so that they are only utilized if the first choice (whatever they normally get from DHCP) is unresponsive or failing - like the issue we saw in this case. We're very happy with this fix as there is no significant change to our normal functionality.

 

 

And I'd like to once again express our sincere appreciation for all your help and assistance - we couldn't have asked for more. It seems that Plusnet customers are very well served by the support they receive. Thank you...

chrisking
Dabbler
Posts: 15
Thanks: 12
Registered: ‎04-09-2018

Re: MQTT connection for IoT device not working

For my part, I would like to add that customers of both Plusnet AND Monitor-IO are very well served by their respective support teams. Very impressed with both.

Chris