cancel
Showing results for 
Search instead for 
Did you mean: 

Issues setting up TP Link X73-DSL Router

standfam
Newbie
Posts: 2
Registered: ‎22-04-2023

Issues setting up TP Link X73-DSL Router

Has anyone else had issues setting up a TP Link X73-DSL Router? 

I am on plusnet fibre to the cabinet and currently using a TP link Archer VR2800 DSL router which is 5 years old and I have purchased a TP Link Deco X73-DSL (confusingly badged AX5400 on the box) to replace this unit.  You can only use the Deco App to set this up and every time I select the Plusnet option on the ISP list the App does not then go on to let me sign into Plusnet (compared to an example set of instructions online the screen/page 14 appears to be missing) but then goes through the internal wifi network etc and I end up with a red light on the unit and no internet connection?  I have tried several attempts/resets to no avail.

 

Thanks

1 REPLY 1
Dan_the_Van
Aspiring Hero
Posts: 2,770
Thanks: 1,328
Fixes: 84
Registered: ‎25-06-2007

Re: Issues setting up TP Link X73-DSL Router

@standfam

You need to be sure it's set as a DSL modem device.

Have tried using "Other" rather than "Plusnet" for the ISP?

You will need the VLAN ID to be 101

Have you watched this https://youtu.be/dEU3LIKaHI4 from the TP-Link site?

HTH