cancel
Showing results for 
Search instead for 
Did you mean: 

Issues connecting to wifi with early 2011 Macbook

debsandian
Newbie
Posts: 3
Registered: 08-07-2017

Issues connecting to wifi with early 2011 Macbook

Ever since we changed to Plusnet 6 months ago, my laptop has had a lot of issues connecting to the wifi network. All my other devices haven't been having issues and my laptop hasn't had trouble connecting to any other wifi networks. Every time I attempt to connect, I'm either prompted for the password (which it should know from the last time it connected) or told it cannot connect and that I should move closer to the router. If I enter the password, 9 times out of 10 it comes back as invalid, which it isn't as I've checked countless times now. Sometimes, after repeated login attempts it succeeds or will manage to automatically connect randomly. This has happened immediately after it has said invalid password or cannot connect, which is very confusing. The only surefire way to connect I have found is to completely reset the router itself and to connect as it is rebooting, which is not ideal. Has anyone else had these issues?

5 REPLIES
Superuser
Superuser
Posts: 10,016
Thanks: 1,549
Fixes: 19
Registered: 22-08-2007

Re: Issues connecting to wifi with early 2011 Macbook

Hi,

A warm welcome to the forums.  It would be useful to know which router you are using and the WiFi settings.  What's the model of the MacBook?

debsandian
Newbie
Posts: 3
Registered: 08-07-2017

Re: Issues connecting to wifi with early 2011 Macbook

Hi, its just the standard ADSL router, Plusnet Hub One (if there's a more exact spec you need, let me know) and my laptop is an early 2011 Macbook Pro 13". Which wifi settings do you need?

Superuser
Superuser
Posts: 10,016
Thanks: 1,549
Fixes: 19
Registered: 22-08-2007

Re: Issues connecting to wifi with early 2011 Macbook

Hi,

There are multiple "standard" ADSL routers supplied by PlusNet to say nothing of the 100's of other options out there.

I'm wondering if the security standard is set to WAP2 which might not be supported by that old MacBook?  Then there's the wifi standards options a/b/g/n to consider.

debsandian
Newbie
Posts: 3
Registered: 08-07-2017

Re: Issues connecting to wifi with early 2011 Macbook

All I can see identifying the router is the name Plusnet Hub One, which is the same as shown here https://www.broadbandchoices.co.uk/guides/hardware/plusnet-hub-one
The security is set to WAP2 only, but so have many other routers that I've connected to. To reiterate, I can connect with my laptop and once I have the connection is good, establishing the connection is the part that can be really temperamental and inconsistent. And I've had issues connecting when restarting the router

Moderator's note by Mike (Mav): Post released from Spam Filter

Plusnet Staff
Plusnet Staff
Posts: 17,640
Thanks: 534
Fixes: 159
Registered: 05-04-2007

Re: Issues connecting to wifi with early 2011 Macbook

There might be a ltitle confusion here as this is actually a fibre line and is the Plusnet Hub One. I'm not sure but I'm going to assume that the Mac doesn't have the ability to connect to a 5Ghz channel? I'd still suggest splitting the channels to see if that helps: https://community.plus.net/t5/My-Router/Devices-stop-working-on-5-GHz-connection-Wifi-drops/m-p/1395...

 

If this post resolved your issue please click the 'This fixed my problem' button
 Chris Parr
 Plusnet Staff