Showing results for 
Search instead for 
Did you mean: 

Hub one as wireless access point problem

Posts: 8
Registered: ‎01-01-2017

Hub one as wireless access point problem

I attempted to use the hub one as a wireless access point only.


Disable dhcp, upnp  and firewall.

Set gateway ip to

Connect via lan (not wan) port to primary router.


All seemed to be going great, worked as expected via ethernet connection to my nearest computer. However when I attempted to connect to the hub via an android phone the hub one hijacked the connection and redirected the device to a no broadband page.

Does anybody know how if I can stop this from happening or am i going to need to buy a new AP

Posts: 11,488
Thanks: 5,110
Fixes: 412
Registered: ‎30-06-2016

Re: Hub one as wireless access point problem


 This should work. The only comment that I would make is that you should set the IP address of the AP to an unused one out of the DHCP range but in the fixed range of the ptimary router. On BT/Plusnet hubs this is the range of

It could be that your phone is trying to use the same IP address as the AP.

Moderator and Customer
If this helped - select the Thumb
If it fixed it,  help others - select 'This Fixed My Problem'

Posts: 8
Registered: ‎01-01-2017

Re: Hub one as wireless access point problem

Thanks for the reply.


I have reverted my configurations for now as the network is in use during the day, I will configure again this evening and check what the phones settings are doing.


The phone is getting a dhcp ip currently from the router in its normal configuration, i expect it will be the same when i check this evening but its still worth checking to see if you are correct.

For reference the configuration I used:


Primary router on

DHCP for network

Excluded from the DHCP pool. - 25 - 125 - 255


AP(hub one) is set to

DHCP off

upnp off

firewall off

Connected at Lan 1


As I said, its weird because I can get a connection when wired to the AP but wifi is hijacked by the router. Ive had this happen in the past too when a bill was over due, the wired connections continued to work while wifi connections redirected to plusnets payment page.


its possible that the dns ive set on the main router isnt getting through to the wifi devices. I dont see why that should cause an issue but il look into it.


If in the end i cant get this working I will likely pick up a router off a well known auction site that doesn't have the firmware of this router. I would hack it and install my own but I don't have a back up, I need the wifi and my main router doesn't have it.