cancel
Showing results for 
Search instead for 
Did you mean: 

Hub One static IP addresses not assigning

tmd63
Hooked
Posts: 5
Registered: 05-01-2017

Hub One static IP addresses not assigning

I am attempting to use the class B IP addresses.

I have set the router on a single address and I have set the DHCP pool with a range of IP addresses.

However, I need to set some static IP addresses outside of the DHCP pool range (to ensure they stay clean) and a single IP at the other end of the IP range to which I can assign the DMZ (no actual device on the network for extremely high security), but I keep getting an "address outside the DHCP pool range" error. But this is the correct idea. The static IP addresses should not be inside the DHCP pool or there will be conflicts between the static IP devices and the devices that the pool attempts to give the same IP address.

How can I set the static IP? say *.*.*.5 and *.*.*.254 whilst the pool is *.*.*.64-*.*.*.128.

3 REPLIES
mssystems
Rising Star
Posts: 269
Thanks: 33
Fixes: 1
Registered: 10-08-2007

Re: Hub One static IP addresses not assigning


tmd63 wrote:

I am attempting to use the class B IP addresses.

I am sure you mean Class C but in any case it's all been CIDR (classless routing) since the early 1990s

 

However, I need to set some static IP addresses outside of the DHCP pool range (to ensure they stay clean)

What does that even mean?

Clearly, 'clean' means something to you but it is not a recognised networking term.

 

and a single IP at the other end of the IP range to which I can assign the DMZ (no actual device on the network for extremely high security),

Sorry but again, this is gibberish. A DMZ is the opposite of high security. Perhaps you could describe what you are trying to achieve, rather than what you are trying to do, as what you are trying to do clealry isn't working.

 

[edit] After re-reading.  Are you on about the DMZ firewall bypass function?  In which case, don't configure it with any address.

 

How can I set the static IP? say *.*.*.5 and *.*.*.254 whilst the pool is *.*.*.64-*.*.*.128.

Much better.

 

The DHCP protocol, and not the Hub One particularly, provides three options to achieve what you are trying to achieve:

1. Assign static addresses by convention, from outside the DHCP pool.

Define the DHCP pool as say 10.10.10.128 to 10.10.10.254. Then manually configure the static devices with IP addresses from outside the pool, say 10.10.10.64 to 10.10.10.127.

 

2. Add reservations for the static addresses within the pool.

Define the DHCP pool as the entire subnet, say 10.10.10.1 to 10.10.10.254. Then add a DHCP reservation for those devices you want to have static addresses. A DHCP reservation maps an IP from the pool to a MAC address. You can configure devices with their static addresses manually, or you can leave them to poll the DHCP server for their reserved IP.

 

3. Exclude the static addresses from the pool.

Define the DHCP pool as the entire subnet, say 10.10.10.1 to 10.10.10.254. Then add a DHCP range exclusion, say 10.10.10.1 to 10.10.10.63. Then manually configure static devices with addresses in the 10.10.10.1 to 10.10.10.63 range, by convention.

 

Note:

i) Ranges are off the top of my head and some DHCP servers will not allow ranges which overlap subnet boundaries.

ii) The PN Hub One is a very cheap router indeed and may not support every DHCP option.

 

tmd63
Hooked
Posts: 5
Registered: 05-01-2017

Re: Hub One static IP addresses not assigning

Sorry for the confusions. Let me try and clarify.

Private IP Addresses
Class Private Networks Address Range
A 10.0.0.0 10.0.0.0 - 10.255.255.255
B 172.16.0.0 - 172.31.0.0 172.16.0.0 - 172.31.255.255
C 192.168.0.0 192.168.0.0 - 192.168.255.255

 

BT has illegally blocked the IANA assigned private class A networks from their hubs. Only class B or class C are available.

If you assign a DHCP pool of 10.10.10.64 to 10.10.10.128. Hub One will not allow a static IP outside this range. If you mark 10.10.10.64 as the first static IP and the device is not started, another device requesting an IP address could be assigned 10.10.10.64 from the default pool as it is within the pool range, when the static device starts, it will attempt to grab 10.10.10.64 and be in conflict with the DHCP assigned device. (not a clean ip assignment).

For the DMZ, if there is a device attached and assigned to a DMZ of 10.10.10.254, anyone from outside can ping into the network and then know to attach the IP address, if there is no DMZ assign, the router responds to an IP request saying there is no device available, this also tells the attacked there is a network to hack. BUT, assigning a DMZ to 10.10.10.254 without a device at that point causes the router to send requests to a blank space with no reply. So hackers do not get any response. They think there is no network (stealth mode)!! I have used this method many times before, but the Hub One will not allow a blank IP address for a DMZ (ie, a null address). Check the Gibbs research Shields Up application. https://www.grc.com/x/ne.dll?bh0bkyd2 . All my old attempts gave all ports at Stealth mode, but the Hub One shows closed ports instead.

I hope this clarifies.

DS
Pro
Posts: 561
Thanks: 115
Fixes: 7
Registered: 06-01-2017

Re: Hub One static IP addresses not assigning

The 10.0.0.0 ip range is reserved by BTOpenzone for their BT-WiFi (used to be known as BTFon)