cancel
Showing results for 
Search instead for 
Did you mean: 

Hub One > always starts saying password wrong, needs reboot, dropping connections

Toursick
Newbie
Posts: 3
Registered: ‎09-01-2020

Hub One > always starts saying password wrong, needs reboot, dropping connections

Have had problems for a few months since joining plusnet but only today I’ve have found the forums. I’ve had a bit of a look at a couple of threads here and it seems I have the .263 firmware that has the problems.

1. Product name: Plusnet Hub
2. Serial number: +081441+NQ90268943
3. Firmware version: Software version 4.7.5.1.83.8.263 Last updated 08/07/19
4. Board version: Plusnet Hub One

Is really the only way for me to fix this, they going on eBay and buying my own better router? If so, I’m absolutely furious. This Yorkshireman will be cutting plusnet loose; this week. I work with artwork and as a tour manager I need to be absolutely certain that when I leave the house, the work I’ve done at home is all synced to the cloud. The last few weeks I’ve had many embarrassing start to a couple of meetings where it is just not synced, and I get home on my iMac say is the Wi-Fi password is disconnected. Then says password is incorrect. No matter how many times I try it still says incorrect so I reboot the router. Then it works! Shoddy. Cheap. Lame.

Does anyone have any suggestions of things I can try, is there a firmware update coming, or is my best bet for ongoing peace of mind to buy separate hardware?

I have just on the past 5 minutes installed a network monitor on my raspberry pi so I’m gonna let that run for a week before I go to plusnet with my findings. I need to sort this ASAP before I go away again.
1 REPLY 1
Baldrick1
Seasoned Hero
Posts: 6,029
Thanks: 2,666
Fixes: 179
Registered: ‎30-06-2016

Re: Hub One > always starts saying password wrong, needs reboot, dropping connections

@Toursick 

If you read this Router board you will see that there is currently no quick fix to the router problem. If switching off the 5GHz band doesn't work I suggest that you connect your important equipment to the router via an Ethernet cable. If this isn't possible get a BT Smarthub 6 off the likes of EBay for very little money. You will find the setting instructions near the top of this board.