cancel
Showing results for 
Search instead for 
Did you mean: 

Hub One and Raspberry Pi 3

kenmau
Newbie
Posts: 6
Registered: ‎25-02-2019

Hub One and Raspberry Pi 3

Recently received new HUB ONE and my Raspberry Pi asked for router password at every boot. Also when password is entered full functionality is not obtained e.g. month and time clock never syncs. All other devices, Desktop, laptop, kindle and smart phone work perfectly. Reinstalling old router and raspberry works fine. Looks like a compatibility problem between Hub one and Raspberry Pi. Anyone shed some light on what the problem might be?

12 REPLIES 12
bobpullen
Community Gaffer
Community Gaffer
Posts: 14,832
Thanks: 2,423
Fixes: 163
Registered: ‎04-04-2007

Re: Hub One and Raspberry Pi 3

You're talking about the wi-fi password presumably? What firmware version is your router running? You can see this in the footer of the router configuration pages.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

kenmau
Newbie
Posts: 6
Registered: ‎25-02-2019

Re: Hub One and Raspberry Pi 3

PlusNet Hub One Software Version  4.7.5.1.83.8.263 updated 23/02/19 

WiFi  security set at WPA2.

Yes it requests WiFi every boot. Then can access web but not fully. Time clock on Raspberry fails to sync and access to google pages denied due to date being incorrect. Reinstalling original PlusNet router and all is fine again.

All other devices work fine except the Raspberry Pi 3 with this router.

MasterOfReality
Plusnet Help Team
Plusnet Help Team
Posts: 1,639
Thanks: 275
Fixes: 57
Registered: ‎26-03-2018

Re: Hub One and Raspberry Pi 3

Hi @kenmau 

 

Pi3's only have 2.4GHz functionality - as did your old TG585 hardware.

 

Your new Hub One broadcasts on both 2.4 & 5GHz - can you try splitting the SSIDs and renaming the 5 so they are running separately? If you then connect the Pi3 to the 2.4GHz frequency it should auto connect every time without needing the WiFI password. 

 

Let us know how this goes. 

 

Thanks, 

MoR

If this post resolved your issue please click the 'This fixed my problem' button
 MoR
 Plusnet Help Team
kenmau
Newbie
Posts: 6
Registered: ‎25-02-2019

Re: Hub One and Raspberry Pi 3

How and to what do I rename the 5?
DS
Champion
Posts: 2,187
Thanks: 464
Fixes: 22
Registered: ‎06-01-2017

Re: Hub One and Raspberry Pi 3

Click the following - http://192.168.1.254/index.cgi?active_page=9105 - and select no under for the sync with 2.4GHz

Then add something like 5-GHz to the SSID

I'd also suggest adding the same to the wireless key.

The above will then give you 2 separate wifi channels and clearly you'd need to reconnect to to this 'new' one for anything using 5GHz. Having said that, none of our devices use the 5GHz spectrum as we find it very unreliable.

kenmau
Newbie
Posts: 6
Registered: ‎25-02-2019

Re: Hub One and Raspberry Pi 3

I've tried "no sync" etc. with 5Mhz and also completely switching 5Mhz off. Still the Raspberry Pi will not remember the wifi password or sync the clock.

bobpullen
Community Gaffer
Community Gaffer
Posts: 14,832
Thanks: 2,423
Fixes: 163
Registered: ‎04-04-2007

Re: Hub One and Raspberry Pi 3

I've a Pi 3 knocking about in the office somewhere I think but I'll need to source an SD card from somewhere. I'll try and get round to this over the next week or two and see if I can replicate the issue.

In the meantime, if anybody else is seeing similar then please shout up.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

bobpullen
Community Gaffer
Community Gaffer
Posts: 14,832
Thanks: 2,423
Fixes: 163
Registered: ‎04-04-2007

Re: Hub One and Raspberry Pi 3

@kenmau, what are you running on the Pi, and what build? Rasbian?

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

kenmau
Newbie
Posts: 6
Registered: ‎25-02-2019

Re: Hub One and Raspberry Pi 3

I'm running a Raspberry Pi3B

Rasbian GNU/Linux 8 (Jessie)

Kernel

Linux raspberrypi 4.9.35-v7+ # 1014 SMP Fri Jun 30 14:47:43 BST 2017

armv 71 GNU/Linux

Just to repeat it is slightly better if 5Mhz disabled but still doesn't remember WiFi password.

Older router no problems at all.

kenmau
Newbie
Posts: 6
Registered: ‎25-02-2019

Re: Hub One and Raspberry Pi 3

I'm fed up with this HUB ONE router. As far as I'm concerned this unit is not fit for purpose. It connects to my Desktop with a direct connection. My laptop and smartphone connect ok BUT my Raspberry PI and NOW TV box will not remember my wifi password or connect. If I reinstall my old router everything connects as they should. 

 

Jubby
Plusnet Help Team
Plusnet Help Team
Posts: 626
Thanks: 115
Fixes: 31
Registered: ‎06-08-2018

Re: Hub One and Raspberry Pi 3

Hi @kenmau,

I'm sorry to hear that you feel this way.

It's unusual that other devices connected to the network reconnect but when a reboot is completed on your NowTV and Raspberry Pi they both appear to forget the wireless profile.

Could you firstly factory reset the Hub One by holding a pin or paper clip in the reset hole until the light on the front goes green and once complete allow up to 15 minutes for the connection to reestablish. While the router is resetting, you should have the option to 'forget' the wireless profile on both devices, please do this for all networks the devices have been connected to.

You would need to then check if the wireless profile is saved on reboot and if the problem persists, forget the networks and split them again.

1) To connect to your Hub One, you will need to open a browser and go to http://192.168.1.254

2) You should come to a page with information about your connection, click 'Advanced Settings' at the top and it will ask you to sign in with a Password. This is located on the back of your router under 'Admin Password'

3) Select the option for 'Wireless' followed by '5 GHz Wireless'. What we want to do to begin with is turn 'Sync with 2.4 GHz Wireless' to 'Off' and update the SSID to be different. The easiest way would be to add '5G' to the end so it is identified as its own connection.

Let us know how you get on.

If this post resolved your issue please click the 'This fixed my problem' button
 Lewis G
 Infrastructure Operations Professional
bobpullen
Community Gaffer
Community Gaffer
Posts: 14,832
Thanks: 2,423
Fixes: 163
Registered: ‎04-04-2007

Re: Hub One and Raspberry Pi 3

 

@kenmau wrote:

I'm running a Raspberry Pi3B

Rasbian GNU/Linux 8 (Jessie)

Kernel

Linux raspberrypi 4.9.35-v7+ # 1014 SMP Fri Jun 30 14:47:43 BST 2017

armv 71 GNU/Linux

Just to repeat it is slightly better if 5Mhz disabled but still doesn't remember WiFi password.

Older router no problems at all.


@kenmau, thanks.

Doesn't help your cause any, but I'm unable to replicate the problem Undecided

Raspbian running the latest Stretch build:

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux

Also using a Pi3B:

pi@raspberrypi:~ $ cat /proc/cpuinfo
processor	: 0
model name	: ARMv7 Processor rev 4 (v7l)
BogoMIPS	: 38.40
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt 
vfpd32 lpae evtstrm crc32
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xd03
CPU revision	: 4

processor	: 1
model name	: ARMv7 Processor rev 4 (v7l)
BogoMIPS	: 38.40
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt 
vfpd32 lpae evtstrm crc32
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xd03
CPU revision	: 4

processor	: 2
model name	: ARMv7 Processor rev 4 (v7l)
BogoMIPS	: 38.40
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt 
vfpd32 lpae evtstrm crc32
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xd03
CPU revision	: 4

processor	: 3
model name	: ARMv7 Processor rev 4 (v7l)
BogoMIPS	: 38.40
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt 
vfpd32 lpae evtstrm crc32
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xd03
CPU revision	: 4

Hardware	: BCM2835
Revision	: a22082
Serial		: 00000000feb83a44

And whether I restart or shutdown and boot from cold, the Wi-Fi adapter comes straight back up and connects to the Hub One without problem (running the latest firmware):

 

pi@raspberrypi:~ $ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:"PLUSNET-SWX7"
           Mode:Managed  Frequency:2.437 GHz  Access Point: 
08:D5:9D:94:22:1E
           Bit Rate=14.4 Mb/s   Tx-Power=31 dBm
           Retry short limit:7   RTS thr:off   Fragment thr:off
           Power Management:on
           Link Quality=45/70  Signal level=-65 dBm
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:11  Invalid misc:0   Missed beacon:0

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵