cancel
Showing results for 
Search instead for 
Did you mean: 

Hub One and BT Essentials Powerline extender

drsimpson2
Newbie
Posts: 2
Registered: ‎17-04-2020

Hub One and BT Essentials Powerline extender

Hello, having trouble with my new Plusnet Hub. Have been using BT Essentials Poweline successfully with a plusnet hub for 18 months and various other router prior to that. Recently renewed contract and changed to fibre, new plusnet hub was sent our and installed. Since the change the new hub will not recognise the power line extender, we have tried plugging it in to all 4 LAN ports and have tried multiple cables. When you go into the hub settings it is not recognising that anything is plugged into the LAN port. There is power to the BT extender and it is showing up as an option in WiFi network lists but if you connect to it there is no internet connection as the hub is not acknowledging its existence. This power line extender has worked fine for several years and across various routers, why will new hub not recognise that the device is connected to it? Any help appreciated.
2 REPLIES 2
Baldrick1
Seasoned Hero
Posts: 6,039
Thanks: 2,671
Fixes: 179
Registered: ‎30-06-2016

Re: Hub One and BT Essentials Powerline extender

@drsimpson2  Welcome to the forum.

Powerline devices are simply a substitute for an Ethernet cable and won't be recognised as a device in the router network display. However if you connect a device to the remote powerline unit this should show up as a device connected to the appropriate router LAN socket..

Powerline units should not be at all bothered what router they are connected to . Have you tried connecting a device directly to an Ethernet port to check that they are working?

The only other possible issue is that the Hub One has additional 1Gbps capability but should also work on the 100Mbps, probably used by your old rputer.  If all else fails try a factory reset on the powerline devices and start again. 

drsimpson2
Newbie
Posts: 2
Registered: ‎17-04-2020

Re: Hub One and BT Essentials Powerline extender

@Baldrick1 Hello and thank you for your response. The odd thing about this is that for a short period of time a few days ago, the router was listing the powerline in its devices list, the name appeared as well as that it was drawing 100Mbs. Even at this point, when the powerline was selected from the wifi list (where it has always appeared with full signal) I can connect to it but there is no internet connection. On the advice we found online we did a hard reset of both devices and after that the router no longer seems to see the powerline and the connection issues remain the same, I can connect to the powerline wifi network but there is. I internet connection. We have checked all four ports work using our desktop computer.
Anyway, thanks for the response and if anything else springs to mind please let me know.