Showing results for 
Search instead for 
Did you mean: 

Got Hub One, not impressed

Posts: 21
Thanks: 5
Fixes: 1
Registered: ‎16-03-2015

Got Hub One, not impressed

Last week got a Hub One replacement to replace the old TG582n+Openreach modem combo on my Fibre Extra connection because a couple of LAN ports on the router blew after a nearby lightning strike (also blew the only LAN port on my TV).


Delivery was quicker than expected or would of been if the stupid postman had actually tried putting the box through the letter box which they claimed was too small for the box (it wasn't by a long shot).


Anyhow, I'm used to ISP supplied routers being crippled and lacking in features (anyone who has/had a TG582n knows how bad they are) but wasn't expecting the problems I'm having.


1) The DL connection is slower than the previous connection, despite the hub claiming a speed of just over 69Mbit/sec which is 2 Mbit/sec lower than before, the actual DL thoughput is down by 8-10Mbit/sec.  I'm now lucky to get over 63Mbit/sec where as previously I was getting a solid 70+ Mbit/sec.  Upload isn't affected as I get the same 18.5Mbit/sec as always.


2) The Wifi was supposed to be one of the routers strong points, well not on mine it isnt, the signal strength for 2.4GHz is a good 8dB+ lower than the 582 and other routers I've tried.  Fine if I'm nearby, but at the back of the house (router is at the front) the signal completely disappears now, where as before it was useable but slow.


3) Boot time takes ages now where as other routers+modem combo took less than half the time the Hub Ones indecipherable light show takes.


4) No Telnet? Really Plusnet?  If a user is technically aware enough to know about telnet, let them use it (even if you do partially cripple functions) like on the 582.  You're very unlikely to get the average Joe poking around at a command prompt and doing "damage" to settings, but it can be a lifesaver for those that know what their doing.


5) Router is buggy and lacks a way to reset the DHCP table among many other deficiencies.

Who in their right mind thought it was a great idea not to allow users to see both connected devices and unconnected DHCP leases in effect, but only allow you to see connected ones?

Even better if you want to change the statically allocated IP from DHCP from the router you have to wait until the new one expires (but the router won't warn you of this), if it hasn't expired then you get into a loop of the router now trying to give you the new IP, but failing to because another now non-connected device still has the lease on it, leading to the device not being able to connect to the network at all! Great if you use the default 24 hour lease time!

On most routers simply rebooting it would clear the table of all or just the non-connected leases, on even better routers you can see the complete table and reset it or delete individual leases. But on the Hub One, no way not even the "Delete Device" option clears the lease, that just hides the name but retains the lease!


Finally) Looking into going OpenWRT on it as I've heard good things about better Wifi on it, amongst the obvious much more configurable experience.

Are ALL Hub One routers HH5a and not the worse (from OpenWRT perspective) HH5b rebadged routers, if not is there anyway to tell without opening it up?


Posts: 11,921
Thanks: 5,311
Fixes: 421
Registered: ‎30-06-2016

Re: Got Hub One, not impressed


They are all HH5a so are ripe for conversion to OpenWRT. The wireless hardware may be reasonable but there have been serious issues with the controlling firmware for at least a year. Just look down the topics on the board to get a flavour.

Many of us use a BT Smarthub 6 instead.

Moderator and Customer
If this helped - select the Thumb
If it fixed it,  help others - select 'This Fixed My Problem'

Aspiring Pro
Posts: 620
Thanks: 62
Fixes: 1
Registered: ‎19-08-2007

Re: Got Hub One, not impressed

The TG582n was probably one of the better devices that plusnet have sent out, everything since has been worse, take for example the  Hub Zero 2704n and the Hub one