cancel
Showing results for 
Search instead for 
Did you mean: 

Google mini set up doesn't work on Plusnet Hub One

jezrichards
Browser
Posts: 2
Registered: ‎03-11-2019

Google mini set up doesn't work on Plusnet Hub One

Yesterday my John Lewis Broadband, supplied by Plusnet, was switched to Plusnet directly and so I swapped my Zyxel router for the Plusnet Hub One router. No problems connecting all devices except for Google Mini whihc had no issues on the Zyxel. I've tried rebooting the devices and re-installing the Google Home app on my iPad but still getting the same problem during set up within the Google Home app - straight after it says 'Connected' (to wifi) I get the splash screen "something went wrong". I'm not sure what to do next, please can you help.

4 REPLIES 4
Baldrick1
Moderator
Moderator
Posts: 8,309
Thanks: 3,758
Fixes: 269
Registered: ‎30-06-2016

Re: Google mini set up doesn't work on Plusnet Hub One

@jezrichards  Welcome to the forum.

I suspect that this is an IPaddress range issue.

Look for a factory reset feature on your Google device. You may have to insert a paperclip or similar into a reset hole. Keep the switch closed for say 20 seconds. This should return the settings to those when you first obtailed the device. Once it has reset set it up again from scratch.

 

Moderator and Customer
If this helped - select the Thumb
If it fixed it,  help others - select 'This Fixed My Problem'

jezrichards
Browser
Posts: 2
Registered: ‎03-11-2019

Re: Google mini set up doesn't work on Plusnet Hub One

Thanks. Tried a factory reset but no joy. It fails at the same point, but this time it’s given the message “speaker is connected to the WiFi network but we were unable to determine if a Google Account was already linked”. Makes zero sense to me.

MisterW
Superuser
Superuser
Posts: 10,592
Thanks: 3,085
Fixes: 228
Registered: ‎30-07-2007

Re: Google mini set up doesn't work on Plusnet Hub One

You can still use the Xyzel router. Just change the PPPoE credentials to you plusnet ones 

See here https://www.plus.net/help/broadband/broadband-connection-settings/ for information

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

dvorak
Moderator
Moderator
Posts: 27,785
Thanks: 5,801
Fixes: 1,399
Registered: ‎11-01-2008

Re: Google mini set up doesn't work on Plusnet Hub One


Moderators Note


This topic has been moved from Fibre to My Router

Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'