cancel
Showing results for 
Search instead for 
Did you mean: 

Google WiFi refuses PPPoE credentials

K1eran
Newbie
Posts: 3
Registered: ‎29-10-2020

Google WiFi refuses PPPoE credentials

I have a Netgear DM200 modem and a Google WiFi router. Unknown to me, the DM200 has routing capabilities which obviously results in a double NAT issue. To get round this I set the DM200 modem to bridge mode and then when to change the Google WiFi WAN mode to PPPoE from DHCP. I entered the PPPoE credentials, which I know are correct, but Google WiFi just kept spinning for ages before giving the message "Oops, something happened" which is ironic because it looks like nothing happened whatsoever on my end! 

I have contacted Google and they said they are aware of some issues of users entering PPPoE details, but they said as far as they can tell, it's the ISP end it's failing at. I'm not 100% sure I believe them on that, but regardless, they have stopped helping me now. 

Does anyone know if Plusnet does indeed not play well with Google WiFi or has anyone ever faced a similar issue and worked out a way around it? I would just put the Google WiFi router in a DMZ, however, the DM200 modem does not have that feature.

Any help would be much appreciated, but after this experience, I strongly recommend anyone thinking of getting Google WiFi, instead, doing a course on networking and buying professional Ubiquiti or Cisco products and setting up your own home network, it looks like it would be far easier. 

1 REPLY 1
dvorak
Moderator
Moderator
Posts: 25,225
Thanks: 4,631
Fixes: 1,174
Registered: ‎11-01-2008

Re: Google WiFi refuses PPPoE credentials


Moderators Note


This topic has been moved from ADSL Broadband to My Router

Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'